summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-15 10:07:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-15 10:10:06 +0200
commitd1e1c4d6f23a2c79b44ea3deb8034b37b0db5fd9 (patch)
tree9630244ef0d390bcd40455d0edd0cb34ba93fb96 /net-dns
parentnet-analyzer/gvmd: fix tests in 9.0.1 (diff)
downloadgentoo-d1e1c4d6f23a2c79b44ea3deb8034b37b0db5fd9.tar.gz
gentoo-d1e1c4d6f23a2c79b44ea3deb8034b37b0db5fd9.tar.bz2
gentoo-d1e1c4d6f23a2c79b44ea3deb8034b37b0db5fd9.zip
net-dns/nsd: Bump to version 4.3.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.3.2.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 4feb12d58a85..4574bae73469 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,3 +1,4 @@
DIST nsd-4.2.4.tar.gz 1148826 BLAKE2B e2508c225d0bebeb9134c6eb3f00dfaf00d2de1a545cf9719b3bf04de8cf4a173ed744ebe5ff50a7062f5fb3135f4e476b9111736442fa358eb6ce20faac8406 SHA512 5d4f546a2a4484b182c65d3337d44596e935bca074c0eda2947b9d128a56db08a00240c6ec9ce22bc9a436e009c00c3283c4a5cbd1163ca4a429eaa92ec54208
DIST nsd-4.3.0.tar.gz 1168198 BLAKE2B 87eb68987dfff84f7ab3038e8c563724d2859e61d28238967d5db272f6783f026eaa3729b73bd16761b8218110bdac7d636307babdaf67b9d35ddeb013ab5ae8 SHA512 8724fdfe9ca07dce6cf73bd0441a5d6b6e8a37f31744aca185e8cff2bde66ba677c189bb0b5bd8c8ec5682cd623bf24c0087ae47630615292b96d89f1d4134c5
DIST nsd-4.3.1.tar.gz 1173582 BLAKE2B 4766beefa9578bf11de9c8aeb4d0729b248893f36ffa72c699a134d0dcf758a247f8a9e31e8da182db982a8717f6cd737e95dac236420b18d34d7dc38bff0e57 SHA512 58b6e964795d6c796b547e1134cef954e5f4adf4e976db830ff7900892327154dab2a607ceadbb99072d6e5495d62c808c8fb8c94359ae93f636d11925c0d261
+DIST nsd-4.3.2.tar.gz 1177939 BLAKE2B 3c1eac9065c5c8aae3b0a98d43cdbc5d757712656efc7ed912b51b91f4b3b84672a15de8476eba40642d766abd9499bbdeaf71aa6e6720a67ac83a1ed0ea274c SHA512 0423aeddc7f60e04718b6ee0954fbdc274576b6ef61472324256e5db696f41e47899b645cbc4d6d8cc2a7dd00190b72f3ef0476c4640dbb80d36ec39f1c9f5c8
diff --git a/net-dns/nsd/nsd-4.3.2.ebuild b/net-dns/nsd/nsd-4.3.2.ebuild
new file mode 100644
index 000000000000..b6ca20a489b4
--- /dev/null
+++ b/net-dns/nsd/nsd-4.3.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}