summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-02-27 02:36:01 +0530
committerZac Medico <zmedico@gentoo.org>2024-02-27 18:59:48 -0800
commite8bf6a7c4aa4f2ca09321ed5056dc9b94faeec48 (patch)
treed340bf46705f61c56fb9a220d32da26c2806d666 /net-dns
parentsys-apps/yarn: adding myself as proxied maintainer (diff)
downloadgentoo-e8bf6a7c4aa4f2ca09321ed5056dc9b94faeec48.tar.gz
gentoo-e8bf6a7c4aa4f2ca09321ed5056dc9b94faeec48.tar.bz2
gentoo-e8bf6a7c4aa4f2ca09321ed5056dc9b94faeec48.zip
net-dns/coredns: add 1.11.2
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35544 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/coredns/Manifest2
-rw-r--r--net-dns/coredns/coredns-1.11.2.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/net-dns/coredns/Manifest b/net-dns/coredns/Manifest
index cea4e5c8dea4..911ab42a2e9f 100644
--- a/net-dns/coredns/Manifest
+++ b/net-dns/coredns/Manifest
@@ -2,3 +2,5 @@ DIST coredns-1.10.1-deps.tar.xz 230970760 BLAKE2B 79e9199256ddcb5c6728aa1cab6260
DIST coredns-1.10.1.tar.gz 632459 BLAKE2B ade57e2f7028cf4c3b69e08396a7cd41cde79c6f0b9b1edeb4c9e73204e9eab295d9b44dce437f337900ca6a622832c6f784f7088b2eed7ac6759e6959e587bd SHA512 6906ecf64b6274f4d3957faec6930ec3ed4de0bddd9e2d72ea2794f43186689ede1f440d7626c5ea66956fdec41e354242f99fa489f1f992b86fede5f580a328
DIST coredns-1.11.1-deps.tar.xz 252844888 BLAKE2B c249a6d52965ac4a6b7e06343d5155e3bc6f0528c11556fda9eb111beec1b4a71ac1b7cc8c76d0c593fedddccf3d3808a0da8145555a804b0284557280bb8dab SHA512 0a22fa25cdbe5e8686612d411b59758ab604a3cf9a92a02eed7b5487506c25dee90c113dcb479fb9da199a31ead2c818ebe856f6f7182967ba13b9852d6e785a
DIST coredns-1.11.1.tar.gz 647236 BLAKE2B 0f2c58608a6a13b57c7df45a8f750ef5b9b6da4be4e5b593cb992141dc6d0e238121789e4ca0b430a100963c3bf08c0257506c812da776ea47a164f83b4fd0cc SHA512 f8752811e9e7913311f47ae13f35c755ac86ea240572be1c1dabc1712b6c42380c60ac385fa9573c77d6fcf4c144df2bc00574f18e8d7b70da21ed8ae4fb87cd
+DIST coredns-1.11.2-deps.tar.xz 261482588 BLAKE2B 39e30800ac1fc404dc60f859b929c4a69614b9f0be8937c3fd7b1a872ec1e163ab4f6a313ed7661d2a101318187aaa2419168c0511cf2108c43ada38db0d1e0b SHA512 91282766d10d28d564d14fb20d8d82808507e509c58b7bb1959bb03a2665a287057aa4d547bfc8cc60ff080eea807af1c57d86bf9ff000125ef0642d8557e47f
+DIST coredns-1.11.2.tar.gz 651994 BLAKE2B 1a7a272756eaf83170e242a573c8a765d6ea7b70fe422d36a87850b600a88287291aa0fe0d49462c34453d4d3c4d33f9497be409379ff8fccc87f41e2195efc1 SHA512 0e90ef4793555bd46aa5ce84cf639c015d1869b407627c69746eb948abff1920f891c45e5f00c0127f23e2c6394c07cc55c1776af840881210f90faa6ec22b40
diff --git a/net-dns/coredns/coredns-1.11.2.ebuild b/net-dns/coredns/coredns-1.11.2.ebuild
new file mode 100644
index 000000000000..52c5778f1173
--- /dev/null
+++ b/net-dns/coredns/coredns-1.11.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module multiprocessing systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="CoreDNS is a DNS server that chains plugins"
+HOMEPAGE="https://github.com/coredns/coredns"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/coredns/coredns.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://github.com/rahilarious/gentoo-distfiles/releases/download/${P}/deps.tar.xz -> ${P}-deps.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+# main
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" MIT BSD ISC MPL-2.0 BSD-2"
+
+SLOT="0"
+IUSE="test"
+# TODO: debug test failure with deps tarball
+RESTRICT="test"
+
+RDEPEND="acct-user/coredns
+ acct-group/coredns"
+
+FILECAPS=(
+ -m 755 'cap_net_bind_service=+ep' usr/bin/${PN}
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_prepare() {
+ default
+ use test || sed -i -e 's|coredns: $(CHECKS)|coredns:|' Makefile
+}
+
+src_compile() {
+ # For non-live versions, prevent git operations which causes sandbox violations
+ # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
+ [[ ${PV} != 9999* ]] && export GITCOMMIT=''
+
+ # Mimicking go-module.eclass's GOFLAGS
+ if use amd64 || use arm || use arm64 ||
+ ( use ppc64 && [[ $(tc-endian) == "little" ]] ) || use s390 || use x86; then
+ local buildmode="-buildmode=pie"
+ fi
+ export BUILDOPTS="-buildvcs=false -modcacherw -v -x -p=$(makeopts_jobs) ${buildmode}"
+
+ default
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+ doman man/*
+
+ newinitd "${FILESDIR}"/coredns.initd coredns
+ newconfd "${FILESDIR}"/coredns.confd coredns
+
+ insinto /etc/coredns/
+ newins "${FILESDIR}"/Corefile.example Corefile
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/coredns.logrotated coredns
+
+ systemd_dounit "${FILESDIR}"/coredns.service
+ newtmpfiles "${FILESDIR}"/coredns.tmpfiles "${PN}.conf"
+}
+
+src_test() {
+ # eclass default '-x' makes tests output unreadable
+ export GOFLAGS="-v -mod=readonly"
+
+ local known_fail=(
+ "TestZoneExternalCNAMELookupWithProxy"
+ "TestMetricsSeveralBlocs"
+ "TestMetricsAvailable"
+ "TestMetricsAvailableAfterReload"
+ "TestMetricsAvailableAfterReloadAndFailedReload"
+ )
+ # concat as '|^Test1$|^Test2$|^Test3...$':
+ local known_fail_re="$(printf '|^%s$' "${known_fail[@]}")"
+ # drop '|' in the begining:
+ known_fail_re="${known_fail_re:1}"
+
+ local working_tests_re="$(
+ # get list of all test:
+ { GOFLAGS="-mod=readonly" go test -list . ./... ||
+ die "Can't get list of tests"; } |
+ # skip "no tests" messages as well as know failures:
+ grep -v -E " |${known_fail_re}" |
+ # format a regexp:
+ sed -z 's/\n/$|^/g'
+ )"
+ # drop '|^' in the end:
+ working_tests_re="^${working_tests_re::-2}"
+
+ go test -race -run "${working_tests_re}" ./... || die "Tests failed"
+ go test -race -run "${known_fail_re}" ./... || ewarn "Known test failure"
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process ${PN}.conf
+}