summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-03 21:11:29 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-03 21:13:00 +0100
commitfb825faab161d53eb2b4450990c06d0b94e6d412 (patch)
tree50b9f14e17c774706e2fec4d0cecf2b61cc4fb4a /net-firewall/shorewall
parentnet-misc/nextcloud-client: 3.1.2 bump (diff)
downloadgentoo-fb825faab161d53eb2b4450990c06d0b94e6d412.tar.gz
gentoo-fb825faab161d53eb2b4450990c06d0b94e6d412.tar.bz2
gentoo-fb825faab161d53eb2b4450990c06d0b94e6d412.zip
net-firewall/shorewall: fix incomplete EAPI 7 migration
When ebuild was migrated to EAPI 7, a call to version_is_at_least() in pkg_postinst wasn't migrated causing upgrade notice not to be displayed. Reported-by: Ben Kohler <bkohler@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/shorewall-5.2.8.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-firewall/shorewall/shorewall-5.2.8.ebuild b/net-firewall/shorewall/shorewall-5.2.8.ebuild
index a388cba86f32..566917fbfb31 100644
--- a/net-firewall/shorewall/shorewall-5.2.8.ebuild
+++ b/net-firewall/shorewall/shorewall-5.2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -428,7 +428,7 @@ pkg_postinst() {
local v
for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least ${MY_MAJOR_RELEASE_NUMBER} ${v}; then
+ if ! ver_test ${v} -ge ${MY_MAJOR_RELEASE_NUMBER}; then
# This is an upgrade
elog "You are upgrading from a previous major version. It is highly recommended that you read"