summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-01 13:04:44 +0000
committerAnthony G. Basile <blueness@gentoo.org>2021-03-11 16:22:39 -0500
commit0201b25bc6e38823a661db86806c6e116f62df50 (patch)
tree07aaf832916c702d11134462c37c7bde98cfb516 /net-firewall
parentwww-client/vivaldi-snapshot: Add version 3.7.2218.21 (diff)
downloadgentoo-0201b25bc6e38823a661db86806c6e116f62df50.tar.gz
gentoo-0201b25bc6e38823a661db86806c6e116f62df50.tar.bz2
gentoo-0201b25bc6e38823a661db86806c6e116f62df50.zip
net-firewall/xtables-addons: Version updated to 3.17.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/xtables-addons/Manifest1
-rw-r--r--net-firewall/xtables-addons/xtables-addons-3.17.ebuild189
2 files changed, 190 insertions, 0 deletions
diff --git a/net-firewall/xtables-addons/Manifest b/net-firewall/xtables-addons/Manifest
index 23f90d2c2990..eef9b295f974 100644
--- a/net-firewall/xtables-addons/Manifest
+++ b/net-firewall/xtables-addons/Manifest
@@ -3,3 +3,4 @@ DIST xtables-addons-3.7.tar.xz 325124 BLAKE2B e7f0bff03f0b77b55cd578c5a77ab4a306
DIST xtables-addons-3.8.tar.xz 324468 BLAKE2B e460e0dc7fcd7037610b44132628b3c39c81477c2e1ef345d939f1c4d5981517789f240d1d2233c6a8e962e326ff9a25c5e66dcf829fb23db66dc8cd78b076d6 SHA512 2e0594ee0e654a19e6bae4f7acb7efd142957418ed44ce92ecd7474bb2f0bfd8dad684be937e8f6ed28395f9d7a6dbea61e7c3259d7b89c05ab10bcad3c04264
DIST xtables-addons-3.9.tar.xz 324380 BLAKE2B d78afec65647c9b83b16e591b3cf6827748d70c02b381c30ee1751aadca6397fcbbe4e7f8e1e9199ae93b07e37ae333358e677b89d2b2c62adeb01e345ce2a33 SHA512 ec7d2ec97c433eb94b893aedfd346393986ef140d7ff95cd8be070cfa397efd87df7d73d36359b81c80618eb8575282a1ea8624c3bf182ddd60d8975f58579b5
DIST xtables-addons-3.13.tar.xz 327104 BLAKE2B 110719a7425060a79df0643ea35cf28ac62af811dde0f6744cf75b632809ff02518366e12ecdf8b017648b85843e689735629fc099b23b21b1999afa3a2e5c69 SHA512 0a9874269dafefe2fc364b41d3f5fb2108ba83dc49457f3aa436b814c8c65fb00f48f664576c8ccf183939edffa854fcf9f9c82a801ac90c0e2b9dc1426e1d85
+DIST xtables-addons-3.17.tar.xz 331272 BLAKE2B 94ec8c8eb318628543b89685482713fe11b80f72416cf10bdf6a5ae27905f130c7a3212481c8c5c0b1f3b1962f7a3707486563d5a0683f3754655f058226b32f SHA512 7d9f80b0f898236e4479f4c618e6f0ad697165c4b4d71fd35d8dc874bccf6376b33ac0fdbf846a8999776854ff175fb8d624b01c12b91142618619c4e6a85706
diff --git a/net-firewall/xtables-addons/xtables-addons-3.17.ebuild b/net-firewall/xtables-addons/xtables-addons-3.17.ebuild
new file mode 100644
index 000000000000..f56d0b954295
--- /dev/null
+++ b/net-firewall/xtables-addons/xtables-addons-3.17.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MODULES_OPTIONAL_USE=modules
+MODULES_OPTIONAL_USE_IUSE_DEFAULT=1
+inherit eutils linux-info linux-mod multilib toolchain-funcs
+
+DESCRIPTION="iptables extensions not yet accepted in the main kernel"
+HOMEPAGE="https://inai.de/projects/xtables-addons/"
+SRC_URI="https://inai.de/files/xtables-addons/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULES="quota2 psd pknock lscan length2 ipv4options ipp2p iface gradm geoip fuzzy condition tarpit sysrq logmark ipmark echo dnetmap dhcpmac delude chaos account"
+
+for mod in ${MODULES}; do
+ IUSE="${IUSE} xtables_addons_${mod}"
+done
+
+DEPEND=">=net-firewall/iptables-1.6.0"
+
+RDEPEND="${DEPEND}
+ xtables_addons_geoip? (
+ app-arch/unzip
+ dev-perl/Net-CIDR-Lite
+ dev-perl/Text-CSV_XS
+ virtual/perl-Getopt-Long
+ )
+"
+
+DEPEND="${DEPEND}
+ virtual/linux-sources"
+
+SKIP_MODULES=""
+
+XA_check4internal_module() {
+ local mod=${1}
+ local version=${3}
+ local kconfigname=${3}
+
+ if use xtables_addons_${mod} && kernel_is -gt ${version}; then
+ ewarn "${kconfigname} should be provided by the kernel. Skipping its build..."
+ if ! linux_chkconfig_present ${kconfigname}; then
+ ewarn "Please enable ${kconfigname} target in your kernel
+ configuration or disable checksum module in ${PN}."
+ fi
+ # SKIP_MODULES in case we need to disable building of everything
+ # like having this USE disabled
+ SKIP_MODULES+=" ${mod}"
+ fi
+}
+
+pkg_setup() {
+ if use modules; then
+ get_version
+ check_modules_supported
+ CONFIG_CHECK="NF_CONNTRACK NF_CONNTRACK_MARK ~CONNECTOR"
+ ERROR_CONNECTOR="Please, enable CONFIG_CONNECTOR if you wish to receive userspace notifications from pknock through netlink/connector"
+ linux-mod_pkg_setup
+
+ if ! linux_chkconfig_present IPV6; then
+ SKIP_IPV6_MODULES="ip6table_rawpost"
+ ewarn "No IPV6 support in kernel. Disabling: ${SKIP_IPV6_MODULES}"
+ fi
+ kernel_is -lt 4 18 && die "${P} requires kernel version >= 4.18"
+ fi
+}
+
+# Helper for maintainer: cheks if all possible MODULES are listed.
+XA_qa_check() {
+ local all_modules
+ all_modules=$(sed -n '/^build_/{s/build_\(.*\)=.*/\L\1/;G;s/\n/ /;s/ $//;h}; ${x;p}' "${S}/mconfig")
+ if [[ ${all_modules} != ${MODULES} ]]; then
+ ewarn "QA: Modules in mconfig differ from \$MODULES in ebuild."
+ ewarn "Please, update MODULES in ebuild."
+ ewarn "'${all_modules}'"
+ fi
+}
+
+# Is there any use flag set?
+XA_has_something_to_build() {
+ local mod
+ for mod in ${MODULES}; do
+ use xtables_addons_${mod} && return
+ done
+
+ eerror "All modules are disabled. What do you want me to build?"
+ eerror "Please, set XTABLES_ADDONS to any combination of"
+ eerror "${MODULES}"
+ die "All modules are disabled."
+}
+
+# Parse Kbuid files and generates list of sources
+XA_get_module_name() {
+ [[ $# != 1 ]] && die "XA_get_sources_for_mod: needs exactly one argument."
+ local mod objdir build_mod sources_list
+ mod=${1}
+ objdir=${S}/extensions
+ # Take modules name from mconfig
+ build_mod=$(sed -n "s/\(build_${mod}\)=.*/\1/Ip" "${S}/mconfig")
+ # strip .o, = and everything before = and print
+ sources_list=$(sed -n "/^obj-[$][{]${build_mod}[}]/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+
+ if [[ -d ${S}/extensions/${sources_list} ]]; then
+ objdir=${S}/extensions/${sources_list}
+ sources_list=$(sed -n "/^obj-m/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+ fi
+ for mod_src in ${sources_list}; do
+ has ${mod_src} ${SKIP_IPV6_MODULES} || \
+ echo " ${mod_src}(xtables_addons:${S}/extensions:${objdir})"
+ done
+}
+
+# Die on modules known to fail on certain kernel version.
+XA_known_failure() {
+ local module_name=$1
+ local KV_max=$2
+
+ if use xtables_addons_${module_name} && kernel_is ge ${KV_max//./ }; then
+ eerror
+ eerror "XTABLES_ADDONS=${module_name} fails to build on linux ${KV_max} or above."
+ eerror "Either remove XTABLES_ADDONS=${module_name} or use an earlier version of the kernel."
+ eerror
+ die
+ fi
+}
+
+src_prepare() {
+ XA_qa_check
+ XA_has_something_to_build
+
+ # Bug #553630#c2. echo fails on linux-4 and above.
+ # This appears to be fixed, at least as of linux-4.2
+ # XA_known_failure "echo" 4
+
+ local mod module_name
+ if use modules; then
+ MODULE_NAMES="compat_xtables(xtables_addons:${S}/extensions:)"
+ fi
+ for mod in ${MODULES}; do
+ if ! has ${mod} ${SKIP_MODULES} && use xtables_addons_${mod}; then
+ sed "s/\(build_${mod}=\).*/\1m/I" -i mconfig || die
+ if use modules; then
+ for module_name in $(XA_get_module_name ${mod}); do
+ MODULE_NAMES+=" ${module_name}"
+ done
+ fi
+ else
+ sed "s/\(build_${mod}=\).*/\1n/I" -i mconfig || die
+ fi
+ done
+ einfo "${MODULE_NAMES}" # for debugging
+
+ sed -e 's/depmod -a/true/' -i Makefile.in || die
+ sed -e '/^all-local:/{s: modules::}' \
+ -e '/^install-exec-local:/{s: modules_install::}' \
+ -i extensions/Makefile.in || die
+
+ use xtables_addons_geoip || sed -e '/^SUBDIRS/{s/geoip//}' -i Makefile.in
+
+ eapply_user
+}
+
+src_configure() {
+ set_arch_to_kernel # .. or it'll look for /arch/amd64/Makefile
+ econf --prefix="${EPREFIX}/" \
+ --libexecdir="${EPREFIX}/$(get_libdir)/" \
+ --with-kbuild="${KV_OUT_DIR}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" V=1
+ use modules && BUILD_PARAMS="V=1" BUILD_TARGETS="modules" linux-mod_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use modules && linux-mod_src_install
+ dodoc -r README doc/*
+ find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+'
+}