summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2021-08-16 09:02:05 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-08-16 09:33:12 +0300
commit32ea62c0acb3a955d00c7fb2b1931776accca940 (patch)
tree54faa35efb202d4db6265f67ead0fcd3d0675925 /net-firewall
parentmedia-plugins/vdr-osdteletext: version bump to 2.2.1 (diff)
downloadgentoo-32ea62c0acb3a955d00c7fb2b1931776accca940.tar.gz
gentoo-32ea62c0acb3a955d00c7fb2b1931776accca940.tar.bz2
gentoo-32ea62c0acb3a955d00c7fb2b1931776accca940.zip
net-firewall/ufw: warn about possible conflicts
Warn about applications that may interfere with ufw. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ufw/ufw-0.36.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-firewall/ufw/ufw-0.36.ebuild b/net-firewall/ufw/ufw-0.36.ebuild
index ca3e55bb0fef..0da5a40cfa58 100644
--- a/net-firewall/ufw/ufw-0.36.ebuild
+++ b/net-firewall/ufw/ufw-0.36.ebuild
@@ -166,6 +166,27 @@ pkg_postinst() {
local print_check_req_warn
print_check_req_warn=false
+ local found=()
+ local apps=("${CATEGORY}/arno-iptables-firewall"
+ "${CATEGORY}/ferm"
+ "${CATEGORY}/firehol"
+ "${CATEGORY}/firewalld"
+ "${CATEGORY}/ipkungfu")
+
+ for exe in "${apps[@]}"
+ do
+ if has_version ''"${exe}"''; then
+ found+=( "${exe}" )
+ fi
+ done
+
+ if [ -n "$found" ]; then
+ echo
+ ewarn "WARNING: Detected other firewall applications:"
+ ewarn "${found[@]}"
+ ewarn "If enabled, these applications may interfere with ufw!"
+ fi
+
if [[ -z "${REPLACING_VERSIONS}" ]]; then
echo
elog "To enable ufw, add it to boot sequence and activate it:"