summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-05-17 10:18:34 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-05-17 10:18:34 -0700
commit43d4129a4e2614dbab36072890ee9bb9f52b3c80 (patch)
treeac03fbadca55ac1a3fc9547e492b545ded440468 /net-firewall
parentnet-firewall/nftlb: add 1.0.4 (diff)
downloadgentoo-43d4129a4e2614dbab36072890ee9bb9f52b3c80.tar.gz
gentoo-43d4129a4e2614dbab36072890ee9bb9f52b3c80.tar.bz2
gentoo-43d4129a4e2614dbab36072890ee9bb9f52b3c80.zip
net-firewall/nftlb: drop 0.6
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftlb/Manifest1
-rw-r--r--net-firewall/nftlb/files/nftlb-0.6-musl.patch72
-rw-r--r--net-firewall/nftlb/files/nftlb-0.6-tests.patch47
-rw-r--r--net-firewall/nftlb/nftlb-0.6.ebuild56
4 files changed, 0 insertions, 176 deletions
diff --git a/net-firewall/nftlb/Manifest b/net-firewall/nftlb/Manifest
index d03ab97bcee8..908c936546ac 100644
--- a/net-firewall/nftlb/Manifest
+++ b/net-firewall/nftlb/Manifest
@@ -1,3 +1,2 @@
-DIST nftlb-0.6.tar.gz 121216 BLAKE2B 98b69c35070eb733a218ac1b1aaa7816de1e4f149c8447fee298b4cf50c57610c816fb178d4115e1e7af5cea0f5b20df36eb5b79655e0d7c69ff30e363985104 SHA512 95b879cfc187fe94cc6876f4af3fe77795c1e0228850cfb38b95206685d9065076b6905d365da7ec5f92773cf8f72f6e441d9140d9b10b02eaf9b6c862c31006
DIST nftlb-1.0.4.tar.gz 199236 BLAKE2B 457fc617af75513330b7c6730a3ee67061d5df4d1faf74a0d57ffaa7ef003e882136a9e0300fe61f1f0235ef752a5d695cfdf9a5e1cecf9b57553d4c9151bfd6 SHA512 89b0dba85029236f55289818c7b7ec6fe6e2e1f33003fc7fb9fa3ae763b96395827ba9d8134aa4ac80f8be0da6e17be132e9293b46c9264d9c49062e4db6688a
DIST nftlb-1.0.tar.gz 195057 BLAKE2B b8237b7ba6f6f61dde726d53b63f2488bf38646984b252317ba0f47727ae91e5f4d58c32c0f0d609b134124efd29fdce2b9c10a981a3892220dac78c84946f48 SHA512 f93db34e4372d8f16e99650f3ade62908ce65722fadd521c6d698ab81b24502f6d82e1945b06b166876ebeb39e1907c97a40776ddf985b035b883e93f62e8766
diff --git a/net-firewall/nftlb/files/nftlb-0.6-musl.patch b/net-firewall/nftlb/files/nftlb-0.6-musl.patch
deleted file mode 100644
index 99990726f05e..000000000000
--- a/net-firewall/nftlb/files/nftlb-0.6-musl.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 4e7b0a9..2396857 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2,6 +2,7 @@ AC_INIT([nftlb], [0.6], [netfilter-devel@vger.kernel.org])
-
- AC_CONFIG_AUX_DIR([build-aux])
- AC_CONFIG_MACRO_DIR([m4])
-+AC_CONFIG_HEADERS([config.h])
- AM_INIT_AUTOMAKE([-Wall foreign subdir-objects
- tar-pax no-dist-gzip dist-bzip2 1.6])
-
-@@ -25,5 +26,7 @@ AC_CHECK_HEADER([ev.h], [EVENTINC="-include ev.h"],
- [EVENTINC="-include libev/ev.h"],
- [AC_MSG_ERROR([ev.h not found])])])
-
-+AC_CHECK_HEADERS([execinfo.h])
-+
- AC_CONFIG_FILES([Makefile src/Makefile])
- AC_OUTPUT
-diff --git a/src/main.c b/src/main.c
-index b6b5ec4..b2a080f 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -18,6 +18,7 @@
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- *
- */
-+#include "config.h"
-
- #include <stdio.h>
- #include <stdlib.h>
-@@ -26,7 +27,10 @@
- #include <syslog.h>
- #include <errno.h>
- #include <unistd.h>
-+
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif /* HAVE_EXECINFO_H */
-
- #include "config.h"
- #include "objects.h"
-@@ -85,6 +89,7 @@ static void nftlb_sighandler(int signo)
- exit(EXIT_SUCCESS);
- }
-
-+#ifdef HAVE_EXECINFO_H
- static void nftlb_trace() {
- void *buffer[255];
- char **str;
-@@ -106,6 +111,7 @@ static void nftlb_trace() {
-
- exit(EXIT_FAILURE);
- }
-+#endif /* HAVE_EXECINFO_H */
-
- int main(int argc, char *argv[])
- {
-@@ -157,8 +163,12 @@ int main(int argc, char *argv[])
-
- if (signal(SIGINT, nftlb_sighandler) == SIG_ERR ||
- signal(SIGTERM, nftlb_sighandler) == SIG_ERR ||
-+#ifdef HAVE_EXECINFO_H
- signal(SIGPIPE, SIG_IGN) == SIG_ERR ||
- signal(SIGSEGV, nftlb_trace) == SIG_ERR) {
-+#else
-+ signal(SIGPIPE, SIG_IGN) == SIG_ERR) {
-+#endif /* HAVE_EXECINFO_H */
- fprintf(stderr, "Error assigning signals\n");
- syslog(LOG_ERR, "Error assigning signals");
- return EXIT_FAILURE;
diff --git a/net-firewall/nftlb/files/nftlb-0.6-tests.patch b/net-firewall/nftlb/files/nftlb-0.6-tests.patch
deleted file mode 100644
index 05baa7ee03a3..000000000000
--- a/net-firewall/nftlb/files/nftlb-0.6-tests.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff --git a/tests/exec_tests.sh b/tests/exec_tests.sh
-index d96eaa3..b7f812d 100755
---- a/tests/exec_tests.sh
-+++ b/tests/exec_tests.sh
-@@ -33,6 +33,8 @@ fi
-
- echo "-- Executing configuration tests"
-
-+retval=0
-+
- for test in `ls -d ${TESTS}`; do
- if [[ ! ${test} =~ ^..._ ]]; then
- continue;
-@@ -55,14 +57,16 @@ for test in `ls -d ${TESTS}`; do
-
- if [ $statusexec -ne 0 ]; then
- echo -e "\e[31mNFT EXEC ERROR\e[0m"
-+ retval=1
- continue;
- fi
-
- #~ nftfile=`echo ${file} | awk -F'.' '{ print $1 }'`
-- $NFTBIN list ruleset > ${reportfile}
-+ $NFTBIN list ruleset > ${reportfile} || retval=1
-
- if [ ! -f ${outputfile} ]; then
- echo "Dump file doesn't exist"
-+ retval=1
- continue;
- fi
-
-@@ -74,6 +78,7 @@ for test in `ls -d ${TESTS}`; do
- rm -f ${reportfile}
- else
- echo -e "\e[31mNFT DUMP ERROR\e[0m"
-+ retval=1
- fi
- done
-
-@@ -83,4 +88,7 @@ fi
-
- if [ "`grep 'nft command error' /var/log/syslog`" != "" ]; then
- echo -e "\e[33m* command errors found, please check syslog\e[0m"
-+ retval=1
- fi
-+
-+exit ${retval}
diff --git a/net-firewall/nftlb/nftlb-0.6.ebuild b/net-firewall/nftlb/nftlb-0.6.ebuild
deleted file mode 100644
index 99822681780a..000000000000
--- a/net-firewall/nftlb/nftlb-0.6.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info autotools
-
-DESCRIPTION="nftables load balancer"
-HOMEPAGE="https://github.com/zevenet/nftlb"
-SRC_URI="https://github.com/zevenet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- net-firewall/nftables:=[modern-kernel]
- dev-libs/jansson:=
- dev-libs/libev:=
-"
-RDEPEND="${DEPEND}"
-
-# tests need root access
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/nftlb-0.6-tests.patch"
- "${FILESDIR}/nftlb-0.6-musl.patch"
-)
-
-pkg_setup() {
- local CONFIG_CHECK="~NF_TABLES ~NFT_NUMGEN
- ~NFT_HASH ~NF_NAT ~IP_NF_NAT"
-
- linux-info_pkg_setup
-
- if kernel_is lt 4 19; then
- eerror "${PN} requires kernel version 4.19 or newer"
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_test() {
- pushd tests >/dev/null || die
-
- sed -e "s:/var/log/syslog:\"${T}/tests.log\":" \
- -i exec_tests.sh || die
-
- ./exec_tests.sh || die "tests failed"
-
- popd >/dev/null || die
-}