summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2023-06-27 11:55:47 +0300
committerSergey Popov <pinkbyte@gentoo.org>2023-06-27 11:58:06 +0300
commit7c8a3effadf1997628b137b7855a1f4e1fe5f969 (patch)
treeb919ba012c93843ee510963a3649f4d2350889df /net-firewall
parentapp-admin/hcloud: remove old (diff)
downloadgentoo-7c8a3effadf1997628b137b7855a1f4e1fe5f969.tar.gz
gentoo-7c8a3effadf1997628b137b7855a1f4e1fe5f969.tar.bz2
gentoo-7c8a3effadf1997628b137b7855a1f4e1fe5f969.zip
net-firewall/ipt_netflow: revision bump
Bump EAPI to 8. Migrate to linux-mod-r1 eclass Sync live ebuild Add missing remote-id in metadata.xml Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-9999-gentoo.patch15
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.6-r1.ebuild111
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-9999.ebuild18
-rw-r--r--net-firewall/ipt_netflow/metadata.xml1
4 files changed, 127 insertions, 18 deletions
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-9999-gentoo.patch b/net-firewall/ipt_netflow/files/ipt_netflow-9999-gentoo.patch
index 675e8b16f725..de797495f0fd 100644
--- a/net-firewall/ipt_netflow/files/ipt_netflow-9999-gentoo.patch
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-9999-gentoo.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -11,7 +11,7 @@ CARGS = @CARGS@
+@@ -13,7 +13,7 @@ CARGS = @CARGS@
SNMPTGSO = /usr/lib/snmp/dlmod/snmp_NETFLOW.so
SNMPCONF = /etc/snmp/snmpd.conf
SNMPLINE = dlmod netflow $(SNMPTGSO)
@@ -9,15 +9,16 @@
# https://www.kernel.org/doc/Documentation/kbuild/modules.txt
# https://www.kernel.org/doc/Documentation/kbuild/makefiles.txt
-@@ -22,31 +22,31 @@ all: ipt_NETFLOW.ko libipt_NETFLOW.so libip6t_NETFLOW.so @SNMPTARGET@
+@@ -24,7 +24,7 @@
ipt_NETFLOW.ko: version.h ipt_NETFLOW.c ipt_NETFLOW.h compat_def.h compat.h Makefile
- @echo Compiling for kernel $(KVERSION)
-- make -C $(KDIR) M=$(CURDIR) modules CONFIG_DEBUG_INFO=y
-+ $(MAKE) -C $(KDIR) M=$(CURDIR) modules CONFIG_DEBUG_INFO=y
+ @echo Compiling $(shell ./version.sh) for kernel $(KVERSION)
+- make -C $(KDIR) M=$(CURDIR) modules
++ $(MAKE) -C $(KDIR) M=$(CURDIR) modules
@touch $@
compat_def.h: gen_compat_def
- ./gen_compat_def > $@
+ ./gen_compat_def > $@-
+@@ -32,24 +32,24 @@
sparse: | version.h ipt_NETFLOW.c ipt_NETFLOW.h compat.h Makefile
@rm -f ipt_NETFLOW.ko ipt_NETFLOW.o
@echo Compiling for kernel $(KVERSION)
@@ -46,7 +47,7 @@
sinstall: | snmp_NETFLOW.so IPT-NETFLOW-MIB.my
@echo " *"
-@@ -66,7 +66,7 @@ sinstall: | snmp_NETFLOW.so IPT-NETFLOW-MIB.my
+@@ -69,7 +69,7 @@
fi
%_sh.o: libipt_NETFLOW.c
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.6-r1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.6-r1.ebuild
new file mode 100644
index 000000000000..ed681389901d
--- /dev/null
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.6-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 toolchain-funcs
+
+DESCRIPTION="Netflow iptables module"
+HOMEPAGE="
+ https://sourceforge.net/projects/ipt-netflow
+ https://github.com/aabc/ipt-netflow
+"
+SRC_URI="https://github.com/aabc/ipt-netflow/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug natevents snmp"
+
+RDEPEND="
+ net-firewall/iptables:0=
+ snmp? ( net-analyzer/net-snmp )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/linux-sources
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0-configure.patch" # bug #455984
+ "${FILESDIR}/${PN}-2.6-gentoo.patch"
+ "${FILESDIR}/${P}-ref_module_fix.patch" # bug #781014
+ "${FILESDIR}/${P}-fix-linux-headers-5.14.patch" # bug #813993
+
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="BRIDGE_NETFILTER ~IP_NF_IPTABLES VLAN_8021Q"
+ use debug && CONFIG_CHECK+=" ~DEBUG_FS"
+ if use natevents; then
+ CONFIG_CHECK+=" NF_CONNTRACK_EVENTS"
+ if kernel_is lt 5 2; then
+ CONFIG_CHECK+=" NF_NAT_NEEDED"
+ else
+ CONFIG_CHECK+=" NF_NAT"
+ fi
+ fi
+
+ IPT_LIB="/usr/$(get_libdir)/xtables"
+ linux-mod-r1_pkg_setup
+}
+
+src_unpack() {
+ default
+
+ mv "${WORKDIR}"/${PN/_/-}-* "${WORKDIR}"/${P} || die
+}
+
+src_prepare() {
+ default
+
+ # Checking for directory is enough
+ sed -i \
+ -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' \
+ configure || die
+}
+
+do_conf() {
+ tc-export CC
+ echo ./configure $*
+ ./configure $* ${EXTRA_ECONF} || die 'configure failed'
+}
+
+src_configure() {
+ local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
+ # this configure script is not based on autotools
+ # ipt-src need to be defined, see bug #455984
+ do_conf \
+ --disable-dkms \
+ --enable-aggregation \
+ --enable-direction \
+ --enable-macaddress \
+ --enable-vlan \
+ --ipt-lib="${IPT_LIB}" \
+ --ipt-src="/usr/" \
+ --ipt-ver="${IPT_VERSION}" \
+ --kdir="${KV_DIR}" \
+ --kver="${KV_FULL}" \
+ $(use debug && echo '--enable-debugfs') \
+ $(use natevents && echo '--enable-natevents') \
+ $(use snmp && echo '--enable-snmp-rules' || echo '--disable-snmp-agent')
+}
+
+src_compile() {
+ local modlist=( ipt_NETFLOW=ipt_netflow )
+ linux-mod-r1_src_compile
+ emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" LD="$(tc-getLD)" OBJDUMP="$(tc-getOBJDUMP)" all
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ use snmp && emake DESTDIR="${D}" SNMPTGSO="/usr/$(get_libdir)/snmp/dlmod/snmp_NETFLOW.so" sinstall
+
+ exeinto "${IPT_LIB}"
+ doexe libip{,6}t_NETFLOW.so
+
+ doheader ipt_NETFLOW.h
+}
diff --git a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
index 986e6de1d7a8..2ea5558fb6e6 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 linux-info linux-mod toolchain-funcs
+inherit git-r3 linux-mod-r1 toolchain-funcs
DESCRIPTION="Netflow iptables module"
HOMEPAGE="
@@ -32,8 +32,6 @@ PATCHES=(
)
pkg_setup() {
- linux-info_pkg_setup
-
local CONFIG_CHECK="BRIDGE_NETFILTER ~IP_NF_IPTABLES VLAN_8021Q"
use debug && CONFIG_CHECK+=" ~DEBUG_FS"
if use natevents; then
@@ -45,11 +43,8 @@ pkg_setup() {
fi
fi
- BUILD_TARGETS="all"
- MODULE_NAMES="ipt_NETFLOW(ipt_netflow)"
IPT_LIB="/usr/$(get_libdir)/xtables"
-
- linux-mod_pkg_setup
+ linux-mod-r1_pkg_setup
}
src_prepare() {
@@ -93,11 +88,13 @@ src_configure() {
}
src_compile() {
+ local modlist=( ipt_NETFLOW=ipt_netflow )
+ linux-mod-r1_src_compile
emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" LD="$(tc-getLD)" OBJDUMP="$(tc-getOBJDUMP)" all
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
use snmp && emake DESTDIR="${D}" SNMPTGSO="/usr/$(get_libdir)/snmp/dlmod/snmp_NETFLOW.so" sinstall
@@ -105,5 +102,4 @@ src_install() {
doexe libip{,6}t_NETFLOW.so
doheader ipt_NETFLOW.h
- dodoc README*
}
diff --git a/net-firewall/ipt_netflow/metadata.xml b/net-firewall/ipt_netflow/metadata.xml
index 288dfc140e2d..1c60427303d3 100644
--- a/net-firewall/ipt_netflow/metadata.xml
+++ b/net-firewall/ipt_netflow/metadata.xml
@@ -14,5 +14,6 @@
</use>
<upstream>
<remote-id type="sourceforge">ipt-netflow</remote-id>
+ <remote-id type="github">aabc/ipt-netflow</remote-id>
</upstream>
</pkgmetadata>