summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-03 11:56:46 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-03 12:19:03 +0100
commit868a4432ae40853116a7679b243042e15209da03 (patch)
treeddf9ca972f6c5362b376f2abaacbb0919d594b22 /net-firewall
parentsci-geosciences/foxtrotgps: Drop old (diff)
downloadgentoo-868a4432ae40853116a7679b243042e15209da03.tar.gz
gentoo-868a4432ae40853116a7679b243042e15209da03.tar.bz2
gentoo-868a4432ae40853116a7679b243042e15209da03.zip
net-firewall/pglinux: Drop .la files, we don't need to specify docdir with eapi6, fix init.d script to call openrc-run, set subslot for NM dep as it will be needed in the future
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/pglinux/pglinux-2.3.1.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/net-firewall/pglinux/pglinux-2.3.1.ebuild b/net-firewall/pglinux/pglinux-2.3.1.ebuild
index a76280158b32..7a3b7bad5dda 100644
--- a/net-firewall/pglinux/pglinux-2.3.1.ebuild
+++ b/net-firewall/pglinux/pglinux-2.3.1.ebuild
@@ -3,8 +3,7 @@
# $Id$
EAPI=6
-
-inherit gnome2-utils linux-info systemd
+inherit eutils gnome2-utils linux-info systemd
MY_P="pgl-${PV}"
@@ -16,6 +15,7 @@ LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="cron dbus logrotate networkmanager qt4 zlib"
+REQUIRED_USE="qt4? ( dbus )"
COMMON_DEPEND="
net-libs/libnetfilter_queue
@@ -27,18 +27,19 @@ COMMON_DEPEND="
dev-qt/qtdbus:4
dev-qt/qtgui:4
|| ( kde-apps/kdesu x11-misc/ktsuss )
- )"
+ )
+"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
- sys-devel/libtool:2"
+ sys-devel/libtool:2
+"
RDEPEND="${COMMON_DEPEND}
net-firewall/iptables
sys-apps/sysvinit
cron? ( virtual/cron )
logrotate? ( app-admin/logrotate )
- networkmanager? ( net-misc/networkmanager )"
-
-REQUIRED_USE="qt4? ( dbus )"
+ networkmanager? ( net-misc/networkmanager:= )
+"
CONFIG_CHECK="~NETFILTER_NETLINK
~NETFILTER_NETLINK_QUEUE
@@ -55,12 +56,16 @@ CONFIG_CHECK="~NETFILTER_NETLINK
~IP_NF_IPTABLES
~IP_NF_TARGET_REJECT"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e 's:/sbin/runscript:/sbin/openrc-run:' pglcmd/init/pgl.gentoo.in || die
+}
src_configure() {
econf \
--localstatedir=/var \
- --docdir=/usr/share/doc/${PF} \
$(use_enable logrotate) \
$(use_enable cron) \
$(use_enable networkmanager) \
@@ -77,6 +82,7 @@ src_install() {
default
keepdir /var/{lib,log,spool}/pgl
rm -rf "${ED%/}"/tmp || die
+ prune_libtool_files --modules
}
pkg_preinst() {