summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2022-01-31 11:00:26 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-01-31 11:00:40 -0800
commitb7fb1e25477f431c2a5b1cfa2ba3362e86a44fdc (patch)
treef2a4e807d7add73509eb2ec094e53d56b4a5110c /net-firewall
parentnet-firewall/nftables: revbump, use distutils eclass (bug #832395) (diff)
downloadgentoo-b7fb1e25477f431c2a5b1cfa2ba3362e86a44fdc.tar.gz
gentoo-b7fb1e25477f431c2a5b1cfa2ba3362e86a44fdc.tar.bz2
gentoo-b7fb1e25477f431c2a5b1cfa2ba3362e86a44fdc.zip
net-firewall/nftables: Sync 9999
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftables/nftables-9999.ebuild36
1 files changed, 21 insertions, 15 deletions
diff --git a/net-firewall/nftables/nftables-9999.ebuild b/net-firewall/nftables/nftables-9999.ebuild
index 944c87fea31f..82923aace969 100644
--- a/net-firewall/nftables/nftables-9999.ebuild
+++ b/net-firewall/nftables/nftables-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..10} )
-
-inherit autotools linux-info python-r1 systemd
+DISTUTILS_OPTIONAL=1
+inherit autotools linux-info distutils-r1 systemd
DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
HOMEPAGE="https://netfilter.org/projects/nftables/"
@@ -56,15 +56,6 @@ PATCHES=(
"${FILESDIR}/${PN}-0.9.8-slibtool.patch"
)
-python_make() {
- emake \
- -C py \
- abs_builddir="${S}" \
- DESTDIR="${D}" \
- PYTHON_BIN="${PYTHON}" \
- "${@}"
-}
-
pkg_setup() {
if kernel_is ge 3 13; then
if use modern-kernel && kernel_is lt 3 18; then
@@ -87,6 +78,12 @@ src_prepare() {
-i files/osf/Makefile.am || die
eautoreconf
+
+ if use python; then
+ pushd py >/dev/null || die
+ distutils-r1_src_prepare
+ popd >/dev/null || die
+ fi
}
src_configure() {
@@ -104,13 +101,21 @@ src_configure() {
$(use_with xtables)
)
econf "${myeconfargs[@]}"
+
+ if use python; then
+ pushd py >/dev/null || die
+ distutils-r1_src_configure
+ popd >/dev/null || die
+ fi
}
src_compile() {
default
if use python; then
- python_foreach_impl python_make
+ pushd py >/dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
fi
}
@@ -134,8 +139,9 @@ src_install() {
systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
if use python ; then
- python_foreach_impl python_make install
- python_foreach_impl python_optimize
+ pushd py >/dev/null || die
+ distutils-r1_src_install
+ popd >/dev/null || die
fi
find "${ED}" -type f -name "*.la" -delete || die