summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-28 11:55:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-28 13:49:10 +0200
commitc0d8ff20ff2d1ef5b361456f25afcc0a6d7e4ad7 (patch)
tree2d435417cfb312f539add155490e81bf7c80e86e /net-firewall
parentnet-firewall/nftables: Bump to version 0.9.1 (diff)
downloadgentoo-c0d8ff20ff2d1ef5b361456f25afcc0a6d7e4ad7.tar.gz
gentoo-c0d8ff20ff2d1ef5b361456f25afcc0a6d7e4ad7.tar.bz2
gentoo-c0d8ff20ff2d1ef5b361456f25afcc0a6d7e4ad7.zip
net-firewall/nftables: Removed old.
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftables/nftables-0.9.0-r1.ebuild89
-rw-r--r--net-firewall/nftables/nftables-0.9.0-r3.ebuild94
-rw-r--r--net-firewall/nftables/nftables-0.9.0.ebuild85
3 files changed, 0 insertions, 268 deletions
diff --git a/net-firewall/nftables/nftables-0.9.0-r1.ebuild b/net-firewall/nftables/nftables-0.9.0-r1.ebuild
deleted file mode 100644
index 09ccb7d40011..000000000000
--- a/net-firewall/nftables/nftables-0.9.0-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools linux-info systemd
-
-DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
-HOMEPAGE="https://netfilter.org/projects/nftables/"
-SRC_URI="https://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~x86"
-IUSE="debug doc +gmp json +readline"
-
-RDEPEND=">=net-libs/libmnl-1.0.3:0=
- gmp? ( dev-libs/gmp:0= )
- json? ( dev-libs/jansson )
- readline? ( sys-libs/readline:0= )
- >=net-libs/libnftnl-1.1.1:0="
-
-DEPEND="${RDEPEND}
- >=app-text/docbook2X-0.8.8-r4
- doc? ( >=app-text/dblatex-0.3.7 )
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig"
-
-S="${WORKDIR}/v${PV}"
-
-pkg_setup() {
- if kernel_is ge 3 13; then
- CONFIG_CHECK="~NF_TABLES"
- linux-info_pkg_setup
- else
- eerror "This package requires kernel version 3.13 or newer to work properly."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --sbindir="${EPREFIX}"/sbin
- $(use_enable debug)
- $(use_enable doc pdf-doc)
- $(use_with !gmp mini_gmp)
- $(use_with json)
- $(use_with readline cli)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- exeinto /usr/libexec/${PN}
- doexe "${FILESDIR}"/libexec/${PN}.sh
-
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- newinitd "${FILESDIR}"/${PN}.init ${PN}
- keepdir /var/lib/nftables
-
- systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
- systemd_enable_service basic.target ${PN}-restore.service
-
- docinto /usr/share/doc/${PF}/skels
- dodoc "${D}"/etc/nftables/*
- rm -R "${D}"/etc/nftables
-}
-
-pkg_postinst() {
- local save_file
- save_file="${EROOT%/}/var/lib/nftables/rules-save"
-
- # In order for the nftables-restore systemd service to start
- # the save_file must exist.
- if [[ ! -f ${save_file} ]]; then
- touch ${save_file}
- fi
-
- elog "If you are creating firewall rules before the next system restart "
- elog "the nftables-restore service must be manually started in order to "
- elog "save those rules on shutdown."
-}
diff --git a/net-firewall/nftables/nftables-0.9.0-r3.ebuild b/net-firewall/nftables/nftables-0.9.0-r3.ebuild
deleted file mode 100644
index 346d321bb376..000000000000
--- a/net-firewall/nftables/nftables-0.9.0-r3.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools linux-info systemd
-
-DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
-HOMEPAGE="https://netfilter.org/projects/nftables/"
-SRC_URI="https://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~x86"
-IUSE="debug doc +gmp json +modern_kernel +readline"
-
-RDEPEND=">=net-libs/libmnl-1.0.3:0=
- gmp? ( dev-libs/gmp:0= )
- json? ( dev-libs/jansson )
- readline? ( sys-libs/readline:0= )
- >=net-libs/libnftnl-1.1.1:0="
-
-DEPEND="${RDEPEND}
- >=app-text/docbook2X-0.8.8-r4
- doc? ( >=app-text/dblatex-0.3.7 )
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig"
-
-S="${WORKDIR}/v${PV}"
-
-pkg_setup() {
- if kernel_is ge 3 13; then
- if use modern_kernel && kernel_is lt 3 18; then
- eerror "The modern_kernel USE flag requires kernel version 3.18 or newer to work properly."
- fi
- CONFIG_CHECK="~NF_TABLES"
- linux-info_pkg_setup
- else
- eerror "This package requires kernel version 3.13 or newer to work properly."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --sbindir="${EPREFIX}"/sbin
- $(use_enable debug)
- $(use_enable doc pdf-doc)
- $(use_with !gmp mini_gmp)
- $(use_with json)
- $(use_with readline cli)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- local mksuffix=""
- use modern_kernel && mksuffix="-mk"
-
- exeinto /usr/libexec/${PN}
- newexe "${FILESDIR}"/libexec/${PN}${mksuffix}.sh ${PN}.sh
- newconfd "${FILESDIR}"/${PN}${mksuffix}.confd ${PN}
- newinitd "${FILESDIR}"/${PN}${mksuffix}.init ${PN}
- keepdir /var/lib/nftables
-
- systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
- systemd_enable_service basic.target ${PN}-restore.service
-
- docinto /usr/share/doc/${PF}/skels
- dodoc "${D}"/etc/nftables/*
- rm -R "${D}"/etc/nftables
-}
-
-pkg_postinst() {
- local save_file
- save_file="${EROOT%/}/var/lib/nftables/rules-save"
-
- # In order for the nftables-restore systemd service to start
- # the save_file must exist.
- if [[ ! -f ${save_file} ]]; then
- touch ${save_file}
- fi
-
- elog "If you are creating firewall rules before the next system restart "
- elog "the nftables-restore service must be manually started in order to "
- elog "save those rules on shutdown."
-}
diff --git a/net-firewall/nftables/nftables-0.9.0.ebuild b/net-firewall/nftables/nftables-0.9.0.ebuild
deleted file mode 100644
index 3a8ef1f307a2..000000000000
--- a/net-firewall/nftables/nftables-0.9.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools linux-info systemd
-
-DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
-HOMEPAGE="https://netfilter.org/projects/nftables/"
-SRC_URI="https://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
-IUSE="debug doc +gmp json +readline"
-
-RDEPEND=">=net-libs/libmnl-1.0.3:0=
- gmp? ( dev-libs/gmp:0= )
- json? ( dev-libs/jansson )
- readline? ( sys-libs/readline:0= )
- >=net-libs/libnftnl-1.1.1:0="
-
-DEPEND="${RDEPEND}
- >=app-text/docbook2X-0.8.8-r4
- doc? ( >=app-text/dblatex-0.3.7 )
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig"
-
-S="${WORKDIR}/v${PV}"
-
-pkg_setup() {
- if kernel_is ge 3 13; then
- CONFIG_CHECK="~NF_TABLES"
- linux-info_pkg_setup
- else
- eerror "This package requires kernel version 3.13 or newer to work properly."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --sbindir="${EPREFIX}"/sbin
- $(use_enable debug)
- $(use_enable doc pdf-doc)
- $(use_with !gmp mini_gmp)
- $(use_with json)
- $(use_with readline cli)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- exeinto /usr/libexec/${PN}
- doexe "${FILESDIR}"/libexec/${PN}.sh
-
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- newinitd "${FILESDIR}"/${PN}.init ${PN}
- keepdir /var/lib/nftables
-
- systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
- systemd_enable_service basic.target ${PN}-restore.service
-}
-
-pkg_postinst() {
- local save_file
- save_file="${EROOT%/}/var/lib/nftables/rules-save"
-
- # In order for the nftables-restore systemd service to start
- # the save_file must exist.
- if [[ ! -f ${save_file} ]]; then
- touch ${save_file}
- fi
-
- elog "If you are creating firewall rules before the next system restart "
- elog "the nftables-restore service must be manually started in order to "
- elog "save those rules on shutdown."
-}