summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-30 00:16:37 +0100
committerSam James <sam@gentoo.org>2021-08-30 00:21:22 +0100
commitd93d65c65a0116ca8a292ba7ab77aa725ce8fd2a (patch)
tree361d95147455f31921fbb592964b6bad510cb8a6 /net-firewall
parentlinux-info.eclass: Replace bit-shift arithmetic by ver_test (diff)
downloadgentoo-d93d65c65a0116ca8a292ba7ab77aa725ce8fd2a.tar.gz
gentoo-d93d65c65a0116ca8a292ba7ab77aa725ce8fd2a.tar.bz2
gentoo-d93d65c65a0116ca8a292ba7ab77aa725ce8fd2a.zip
net-firewall/firewalld: add 1.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-1.0.1.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index f695b67b7c11..ede989b01232 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -2,3 +2,4 @@ DIST firewalld-0.7.1.tar.gz 2326020 BLAKE2B 1ab435bfd97608ce246657a24daebe6ca83f
DIST firewalld-0.7.3.tar.gz 1247590 BLAKE2B 80b34749ab47fa3f2733c6c2fe6dec9483b38baa3485c91875888ecce4bacc16a05e69d5734aaed017408ec2ba8b33155aa0c08e93b1f8eac5c6708682edf238 SHA512 49ab1403b29b215ef69d54baf9060826917ab2a6d632f0a53b458170576639e74580e4399e5c78a74bf12a4999479db86aadacbc17c749ab25e9de8ed686146f
DIST firewalld-0.9.1.tar.gz 1335885 BLAKE2B 0952039f1f50d6395921bea5ad031c5d21d9be04c5d0b09074f9fce76c29a1ab5acf23f0ee8442ae0c2a4e12e28a42edae40f9b536b007cf747c4eab60e43a04 SHA512 aa29fb8926285d6cc7aff318921cf84cacd7c3e4cecacd9b48bf8b5e16502ceedd8ec6cd78546d2373d084230277e0f43c1e655441eda76fe898960d6f2d46b6
DIST firewalld-0.9.3.tar.gz 1309371 BLAKE2B 78a86f9c14ed8cc2497f3b79e4be627a28dcdcd4e8117438cb24142643bd16dc624196a80ce2c9f81c63f745c1b1430b2e8c2f3f1061f98fd4fa58f6227def81 SHA512 6ae45652225a3b983c0f67307208df171cf4794da5873a84b4a827753b8d93736f0538e06d31cd8177446827691886a58a493b6be1dcf6efd1a550f8886522f4
+DIST firewalld-1.0.1.tar.gz 1306854 BLAKE2B 6dd68ed4219eb7d266e6bfa4d626dec51dcf28aae84609c9b87afa8e397179b0565bc8144c106c8ae8770293b371552b930679ec8a1204b2c9cb1f75e39c7013 SHA512 875af09caface324f7b5cfb0a87df5d309ff2e9e51d6d3a797f46f951ba95f4e1bc9f9f046f5191fafdef878dc65baf1b77a25a17f5aaf2f32bb1e1f782f1f8c
diff --git a/net-firewall/firewalld/firewalld-1.0.1.ebuild b/net-firewall/firewalld/firewalld-1.0.1.ebuild
new file mode 100644
index 000000000000..d99dc6ac2166
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-1.0.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit autotools bash-completion-r1 gnome2-utils linux-info plocale python-single-r1 systemd xdg-utils
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://www.firewalld.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gui +nftables +iptables"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !!net-firewall/gshield
+ iptables? (
+ net-firewall/iptables[ipv6]
+ net-firewall/ebtables
+ net-firewall/ipset
+ nftables? ( net-firewall/nftables[xtables(+)] )
+ )
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ nftables? ( >=net-firewall/nftables-0.9.4[python,json] )
+ ')"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2"
+BDEPEND=">=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+RESTRICT="test" # bug 650760
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
+
+PLOCALES="ar as ast bg bn_IN ca cs da de el en_GB en_US es et eu fa fi fr gl gu hi hu ia id it ja ka kn ko lt ml mr nl or pa pl pt pt_BR ru si sk sq sr sr@latin sv ta te tr uk zh_CN zh_TW"
+
+pkg_setup() {
+ local CONFIG_CHECK="~NF_CONNTRACK ~NETFILTER_XT_MATCH_CONNTRACK"
+
+ # kernel >= 4.19 has unified a NF_CONNTRACK module, bug 692944
+ if kernel_is -lt 4 19; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_IPV6"
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ plocale_find_changes "po" "" ".po"
+ plocale_get_locales | sed -e 's/ /\n/g' > po/LINGUAS
+}
+
+src_configure() {
+ python_setup
+
+ local econf_args=(
+ --enable-systemd
+ $(use_with iptables iptables "${EPREFIX}/sbin/iptables")
+ $(use_with iptables iptables_restore "${EPREFIX}/sbin/iptables-restore")
+ $(use_with iptables ip6tables "${EPREFIX}/sbin/ip6tables")
+ $(use_with iptables ip6tables_restore "${EPREFIX}/sbin/ip6tables-restore")
+ $(use_with iptables ebtables "${EPREFIX}/sbin/ebtables")
+ $(use_with iptables ebtables_restore "${EPREFIX}/sbin/ebtables-restore")
+ $(use_with iptables ipset "${EPREFIX}/usr/sbin/ipset")
+ --with-systemd-unitdir="$(systemd_get_systemunitdir)"
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ )
+
+ econf "${econf_args[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # Get rid of junk
+ rm -rf "${D}/etc/sysconfig/" || die
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -rf "${D}/etc/xdg/autostart" || die
+ rm -f "${D}/usr/bin/firewall-applet" || die
+ rm -f "${D}/usr/bin/firewall-config" || die
+ rm -rf "${D}/usr/share/applications" || die
+ rm -rf "${D}/usr/share/icons" || die
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}