summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-07 10:12:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-07 10:12:23 +0100
commitf6961a2fa3404b8866a2bb8764dc762464b3cf12 (patch)
treee8a0bcbacad733619d3213b736a1dabd187ab5c6 /net-firewall
parentapp-misc/ca-certificates: Bump to version 20170717.3.36 (diff)
downloadgentoo-f6961a2fa3404b8866a2bb8764dc762464b3cf12.tar.gz
gentoo-f6961a2fa3404b8866a2bb8764dc762464b3cf12.tar.bz2
gentoo-f6961a2fa3404b8866a2bb8764dc762464b3cf12.zip
net-firewall/nftables: Bump to version 0.8.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftables/Manifest1
-rw-r--r--net-firewall/nftables/nftables-0.8.3.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-firewall/nftables/Manifest b/net-firewall/nftables/Manifest
index 08868d16b558..81edd076bb7f 100644
--- a/net-firewall/nftables/Manifest
+++ b/net-firewall/nftables/Manifest
@@ -1,3 +1,4 @@
DIST nftables-0.8.1.tar.gz 329098 BLAKE2B d6e5803e146ed5883761d620ef1549e883a2947b495a9b1ff2a40c70794ab5125596e0802fb60bff6d1a21e666c94338b92a22ef3c4c1b66e0b4521cd3dfb78d SHA512 5cae3a411f24adc17786b45d4ed8256eb44fd90f044f7f5d7ddebb1875d0317197e13128d9b22115cd7fcdfa21dba3c539de325ecedce707f8766c93e03efc75
DIST nftables-0.8.2.tar.gz 332736 BLAKE2B 9730735a7112a80e257ee2dc4f7f957b6d62964d5bbf85bbed8d375e07ef86021f21f027e889b913bc5862ccda57942a4411fda7e642c949d1fbf37e640e5b5a SHA512 cc97937014c65bb2489759ac2f603d354be8d3b60f6e0f0f8c2598dc59a66d8701f426c9f91bc4b17d0f574832835ffc38de054a554bda02e09c617fd2a8129b
+DIST nftables-0.8.3.tar.gz 336963 BLAKE2B 534768559254d1c797ae84d97487dfca12bd2ab07170a8670778b46c7a6c854858b8ac670eedb0d0c443b457b4ad15d03c0a6b54ffa5ecde78ef538df71ec090 SHA512 cffea523fe2eee5937f30fe3d5215e5890dfc089d6f16d07090ef922e2782df53fe268d467734a1b6a604d7f16bca52ada3e48cce7699a59dd7a092294930332
DIST nftables-0.8.tar.gz 327629 BLAKE2B a484c22ac010f68fc7458c12cabd0c35e474a0bf81fa4edbefba12d75b424898d38adb11a7fbb4542efbbb2d14be823701b3d9ced7b9fd669338366733fa169b SHA512 90ffebc338c121334ca42822793b6fdeff48390e755c690308919de47064b53f9af735a2c2914e5255f1bddec90484599337d4cdd67f7a01a3956deefcef9fcb
diff --git a/net-firewall/nftables/nftables-0.8.3.ebuild b/net-firewall/nftables/nftables-0.8.3.ebuild
new file mode 100644
index 000000000000..a38042ed9a69
--- /dev/null
+++ b/net-firewall/nftables/nftables-0.8.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
+HOMEPAGE="https://netfilter.org/projects/nftables/"
+SRC_URI="https://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+IUSE="debug doc +gmp +readline"
+
+RDEPEND=">=net-libs/libmnl-1.0.3:0=
+ gmp? ( dev-libs/gmp:0= )
+ readline? ( sys-libs/readline:0= )
+ >=net-libs/libnftnl-1.0.9:0="
+
+DEPEND="${RDEPEND}
+ >=app-text/docbook2X-0.8.8-r4
+ doc? ( >=app-text/dblatex-0.3.7 )
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+S="${WORKDIR}/v${PV}"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sbindir="${EPREFIX}"/sbin
+ $(use_enable doc pdf-doc)
+ $(use_enable debug)
+ $(use_with readline cli)
+ $(use_with !gmp mini_gmp)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodir /usr/libexec/${PN}
+ exeinto /usr/libexec/${PN}
+ doexe "${FILESDIR}"/libexec/${PN}.sh
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ keepdir /var/lib/nftables
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
+ systemd_enable_service basic.target ${PN}-restore.service
+}
+
+pkg_postinst() {
+ local save_file
+ save_file="${EROOT%/}/var/lib/nftables/rules-save"
+
+ # In order for the nftables-restore systemd service to start
+ # the save_file must exist.
+ if [[ ! -f ${save_file} ]]; then
+ touch ${save_file}
+ fi
+
+ elog "If you are creating firewall rules before the next system restart "
+ elog "the nftables-restore service must be manually started in order to "
+ elog "save those rules on shutdown."
+}