summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-08-17 08:43:47 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-08-17 08:52:16 -0500
commitfa9ddf5093c3c25d62058128b868307b04dfe059 (patch)
tree61cbc4a4c81e5b00c4213a2db740b4de8fea9146 /net-firewall
parentnet-misc/tn5250: Bump eapi, stop using deprecated python eclass (python doesn... (diff)
downloadgentoo-fa9ddf5093c3c25d62058128b868307b04dfe059.tar.gz
gentoo-fa9ddf5093c3c25d62058128b868307b04dfe059.tar.bz2
gentoo-fa9ddf5093c3c25d62058128b868307b04dfe059.zip
net-firewall/firewalld: version bump to 0.4.3.3 (CVE-2016-5410), bug #591458
Version 0.4.3.3 contains upstream fixes for CVE-2016-5410 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-0.4.3.3.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index 8619bd558c08..d63f2bd1d667 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -1,2 +1,3 @@
DIST firewalld-0.3.13.tar.bz2 561948 SHA256 bca88cbce4290b6959b3c0eea560e7f19c7cf2f563caca585b7db5cd2fca8ac9 SHA512 987ea3e243f87b8ded2f9627b4efc9649a22d878d19b6b760ba1a281e9e7280abcda558feebe6bd30e1cd27e7277a8ec99a7da623c29f04ab290c1d7ac3d6789 WHIRLPOOL 795f63fa5415c37ea9c6a835860dca4eb71879d1d69fcd6fbb022d0c4b4ab507d74e0e17098724846bd97246be3a98fab1d25134df69c9ac25db2fb77508b159
DIST firewalld-0.4.2.tar.bz2 649581 SHA256 329e44b7d8de2400222d602d6c87c368865531ffe4004c392803dbe55717068e SHA512 4e1ad32878393beaec70f91f462785c99464ce3ec610b68b20862af2bbb631b1bcffd0e68cff441944d5e272d63051dc783a7f5c0256c7a191e2340dab8f29a2 WHIRLPOOL 01b8928d9b570b70a358c68a2220712b329aace9c52905cc5420e9881575660c44b395d1b5f1ffc2550d74bcf42939db0a66fa9bdc02cb1d95959ab7a50072cd
+DIST firewalld-0.4.3.3.tar.bz2 679617 SHA256 e57d851e4f1aa65927e055d3e73b7a29a5ae37de51671ce1885e030fe6e0b6d4 SHA512 21cb91b9545263f6da4a6ff218c939b610c7fe5dba2ad509803673d9c01cf6fecb4ab32bacf1a04e3d579fd9699a03760475285f824a6641902037c81ad2243a WHIRLPOOL 89077aefa28752e51472510bc5080c61e1f6051062efd4aaac08c8a60879b1c3d00db9d9ad7c33d8a49d8868fb9796c0bf945c869a470380f9e2ab017c45ab41
diff --git a/net-firewall/firewalld/firewalld-0.4.3.3.ebuild b/net-firewall/firewalld/firewalld-0.4.3.3.ebuild
new file mode 100644
index 000000000000..ced98904642f
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.4.3.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+#BACKPORTS=
+
+inherit autotools eutils gnome2-utils python-r1 systemd multilib bash-completion-r1
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://www.firewalld.org/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2
+ ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6]
+ net-firewall/ipset
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --enable-systemd \
+ --with-iptables="${EROOT}/sbin/iptables" \
+ --with-ip6tables="${EROOT}/sbin/ip6tables" \
+ --with-iptables_restore="${EROOT}/sbin/iptables-restore" \
+ --with-ip6tables_restore="${EROOT}/sbin/ip6tables-restore" \
+ --with-ebtables="${EROOT}/sbin/ebtables" \
+ --with-ebtables_restore="${EROOT}/sbin/ebtables-restore" \
+ "$(systemd_with_unitdir 'systemd-unitdir')" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ # manually split up the installation to avoid "file already exists" errors
+ emake -C config DESTDIR="${D}" install
+ emake -C po DESTDIR="${D}" install
+ emake -C shell-completion DESTDIR="${D}" install
+ emake -C doc DESTDIR="${D}" install
+
+ install_python() {
+ emake -C src DESTDIR="${D}" pythondir="$(python_get_sitedir)" install
+ python_optimize
+ }
+ python_foreach_impl install_python
+
+ python_replicate_script "${D}"/usr/bin/firewall-{offline-cmd,cmd,applet,config}
+ python_replicate_script "${D}/usr/sbin/firewalld"
+
+ # Get rid of junk
+ rm -rf "${D}/etc/rc.d/"
+ rm -rf "${D}/etc/sysconfig/"
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -rf "${D}/etc/xdg/autostart"
+ rm -f "${D}/usr/bin/firewall-applet"
+ rm -f "${D}/usr/bin/firewall-config"
+ rm -rf "${D}/usr/share/applications"
+ rm -rf "${D}/usr/share/icons"
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}