summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-10 07:54:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-10 07:56:17 +0100
commit3e0d35af149c5a90556fd655456a2ba4e25fbaee (patch)
tree5142fc617b11dec759753db6a5588bb9c849d57f /net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
parentnet-fs/curlftpfs: fix sys-fs/fuse SLOT (diff)
downloadgentoo-3e0d35af149c5a90556fd655456a2ba4e25fbaee.tar.gz
gentoo-3e0d35af149c5a90556fd655456a2ba4e25fbaee.tar.bz2
gentoo-3e0d35af149c5a90556fd655456a2ba4e25fbaee.zip
net-fs/curlftpfs: modernize to EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild')
-rw-r--r--net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild b/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
index ee8b52e0a00f..04a3efebf10f 100644
--- a/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
+++ b/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="File system for accessing ftp hosts based on FUSE"
HOMEPAGE="http://curlftpfs.sourceforge.net/"
@@ -21,18 +21,20 @@ RDEPEND=">=net-misc/curl-7.17.0
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit_filesize.patch
+ "${FILESDIR}"/${PN}-0.9.2-darwin.patch
+ "${FILESDIR}"/${PN}-0.9.2-memleak.patch
+ "${FILESDIR}"/${PN}-0.9.2-memleak-nocache.patch
+ "${FILESDIR}"/${PN}-0.9.2-fix-escaping.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-64bit_filesize.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-darwin.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-memleak.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-memleak-nocache.patch
- epatch "${FILESDIR}"/${PN}-0.9.2-fix-escaping.patch
+ default
# automake-1.13.1 obsoletes AM_* bit #469818
sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
- epatch_user
-
eautoreconf
}