summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-10 14:18:27 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-10 14:18:27 +0200
commitcc681f2469938f87f9cf1cc6e08b8275c9cde6cc (patch)
tree48cfa7cccd8f8c26d229feeb3b607bf325f398cc /net-fs/minio/minio-0_pre20170805.ebuild
parentsys-cluster/kube-scheduler: Remove old (diff)
downloadgentoo-cc681f2469938f87f9cf1cc6e08b8275c9cde6cc.tar.gz
gentoo-cc681f2469938f87f9cf1cc6e08b8275c9cde6cc.tar.bz2
gentoo-cc681f2469938f87f9cf1cc6e08b8275c9cde6cc.zip
net-fs/minio: Version bump to 0_pre20170805
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-fs/minio/minio-0_pre20170805.ebuild')
-rw-r--r--net-fs/minio/minio-0_pre20170805.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-fs/minio/minio-0_pre20170805.ebuild b/net-fs/minio/minio-0_pre20170805.ebuild
new file mode 100644
index 000000000000..c3d427448b64
--- /dev/null
+++ b/net-fs/minio/minio-0_pre20170805.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/minio/minio"
+VERSION="2017-08-05T00-00-53Z"
+EGIT_COMMIT="aeafe668d8b6d25caac671d59e2b0f0473ce35d0"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="An Amazon S3 compatible object storage server"
+HOMEPAGE="https://github.com/minio/minio"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "s/time.Now().UTC().Format(time.RFC3339)/\"${VERSION}\"/"\
+ -e "s/-s //"\
+ -e "/time/d"\
+ -e "s/+ commitID()/+ \"${EGIT_COMMIT}\"/"\
+ src/${EGO_PN}/buildscripts/gen-ldflags.go || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ MINIO_RELEASE="${VERSION}"
+ go run buildscripts/gen-ldflags.go
+ GOPATH="${S}" go build --ldflags "$(go run buildscripts/gen-ldflags.go)" -o ${PN} || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dodoc -r README.md CONTRIBUTING.md MAINTAINERS.md docs
+ dobin minio
+ popd || die
+}