summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@binghamton.edu>2016-05-15 23:46:45 -0400
committerIan Delaney <idella4@gentoo.org>2016-05-17 13:48:12 +0800
commit80446750d4dc314dfe9080f69e22b03385e3d16d (patch)
treeffe89b59d1f031ce17be743b326ffa038354c89e /net-fs
parentnet-analyzer/cacti: Stable for HPPA (bug #582996). (diff)
downloadgentoo-80446750d4dc314dfe9080f69e22b03385e3d16d.tar.gz
gentoo-80446750d4dc314dfe9080f69e22b03385e3d16d.tar.bz2
gentoo-80446750d4dc314dfe9080f69e22b03385e3d16d.zip
net-fs/davfs2: bump to 1.5.4, eapi bump, add nls flag, update license
- Bump to EAPI 6 - Add a "nls" USE flag along with the gettext build time, and libintl and libiconv runtime deps - The source is licensed with GPL-3+ now Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1475 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/davfs2/Manifest1
-rw-r--r--net-fs/davfs2/davfs2-1.5.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-fs/davfs2/Manifest b/net-fs/davfs2/Manifest
index 2ceb54c7f5c4..400f0b94a5e5 100644
--- a/net-fs/davfs2/Manifest
+++ b/net-fs/davfs2/Manifest
@@ -1 +1,2 @@
DIST davfs2-1.5.2.tar.gz 464458 SHA256 be34a19ab57a6ea77ecb82083e9e4c1882e12b2de64257de567ad5ee7a17b358 SHA512 c912049e23b76bda19c2ae2d07bc2b1da7ed9bf82b338c57c0f9fb8a3144cbbb52a0e8f8c2f8996342c7aa434470d062996c30bbbe0f1c6623c81af6414fbb45 WHIRLPOOL b1147d93f188635293726cad27a5ef8f79ab4dd102c59143c7bffef26f513633ca16f4328b053cc4c430fa9112dbbf468e0d199695225bbe6ca8c9e92a96b633
+DIST davfs2-1.5.4.tar.gz 478377 SHA256 c9c4e0f0912a782386216b2147eb9c36c47f193b8fcf3d637719e0b9fe7c96e0 SHA512 08550f171f4b196f55f3fb71c6c75ed24063f8a5afc31c52502d0c911cf7aca4da01f7a123269d410dadc497c44ef5a3573e455aca6eafe48eb86f18429b94b2 WHIRLPOOL f22962bf770867b2e5b54f810004325d3d782c43448787223de4c203f959630fb0a43ab61bff355563fb1bee3a47444e1ee9baeb47f13b200c48852eb4332972
diff --git a/net-fs/davfs2/davfs2-1.5.4.ebuild b/net-fs/davfs2/davfs2-1.5.4.ebuild
new file mode 100644
index 000000000000..469e30343889
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.5.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
+HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ net-libs/neon
+ sys-libs/zlib
+ nls? ( virtual/libintl virtual/libiconv )
+"
+DEPEND="${REPEND}
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ enewgroup davfs2
+}
+
+src_configure() {
+ econf dav_user=nobody --enable-largefile $(use_enable nls)
+}
+
+pkg_postinst() {
+ elog
+ elog "Quick setup:"
+ elog " (as root)"
+ elog " # gpasswd -a \${your_user} davfs2"
+ elog " # echo 'http://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab"
+ elog " (as user)"
+ elog " \$ mkdir -p ~/dav"
+ elog " \$ mount ~/dav"
+ elog
+}