summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-07-20 12:35:42 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-07-20 12:40:43 -0400
commitab0d02707529ee43577fb2b525176d12012ff083 (patch)
treea8f61ac1a9b72a11fcd5007d472ab46853d1b6ce /net-fs
parentprofiles: Update kde package.use (diff)
downloadgentoo-ab0d02707529ee43577fb2b525176d12012ff083.tar.gz
gentoo-ab0d02707529ee43577fb2b525176d12012ff083.tar.bz2
gentoo-ab0d02707529ee43577fb2b525176d12012ff083.zip
net-fs/openafs-kernel: Vbump to 1.6.18.2; Support Linux 4.6; Drop RODATA
As of this release, CONFIG_DEBUG_RODATA=n is no longer required for any kernel available in Gentoo. Users are urged to turn CONFIG_DEBUG_RODATA back on if they have no other reason for keeping it off. Package-Manager: portage-2.2.28
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs-kernel/Manifest2
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.6.18.2.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/net-fs/openafs-kernel/Manifest b/net-fs/openafs-kernel/Manifest
index 8e0786579486..f0650db1ea86 100644
--- a/net-fs/openafs-kernel/Manifest
+++ b/net-fs/openafs-kernel/Manifest
@@ -1,3 +1,5 @@
DIST openafs-1.6.17-src.tar.bz2 14607107 SHA256 96413a2dbffdc9170cc5dde6aa5ad0ae2383c6106994285ed8f186928813a398 SHA512 3ca61a7731c9bd9bae7da2f7b3900438fcc9f75c95b354574389c2203af2ec0a7b4dcaaf13a437743477fcad8a46c3bbb8c68255a976b9a9917b8f0a0cdf028f WHIRLPOOL 92de51878836a721e6fadbe2f6c7a8069ecf622a08fd05e3a01d8fef376bd2e18e9f3b4715d42a26e8d5f1d665f91924520ed6928ed1f460bac49b1bc906e129
DIST openafs-1.6.18-src.tar.bz2 14645551 SHA256 b3c35e7be6b6c86b91e7c699fd015f53c87bc19d1ae8ec3ec9cda6b97327d3b6 SHA512 e4c9afe857bed240ba2c8fdb0b22e680c10d3bed4cde8966c314610982c5fa6e6ead81bcf869a3cc9d41b8bbcefaaf2d165e8ae6dd6606ebcb5b986fc1aecee8 WHIRLPOOL 62cc93f6a3a549dae4ad111cdaaba907502c75329cbfd0052d4026df29323e35782e4cd9f073c71ac7df42258c5f4a18ba8e0820dbf2dce44a1627ed107b91dc
+DIST openafs-1.6.18.2-src.tar.bz2 14652869 SHA256 1e0749b33a20700651ec61436a25ad8d047ffc189a2d024614e7aeedaef57483 SHA512 a9690349c665baa29171d8256e41cac817599e742880bbb02382bdda67a1adc0b4910aa2a1e92dea4867cc25832b27b6561c4ff05f5103a0da952e60b6facfac WHIRLPOOL 830ee1e4285c3e8f5f6b5eac2dcecfb75d5007a9960525d53438ee71135aed269f558ef1fa6a07bd72dd911f496597db6bc085ef2cc342f543cd0e2edfde53b4
DIST openafs-patches-20160321.tar.xz 10940 SHA256 b8919d4db7ac962922f797b5f6a855de27f019f43163d4362946ae9b80d73278 SHA512 581f2248cd9926e79d9b2d30d5e9e3349794e8751e0382fd47c59d5d131f7d814744ed9926f008525466afa9c783e59b2f10d3def5d37966aad98c04873cf4c5 WHIRLPOOL 6da7619158dccb5fcc86e73d9d2f0c83f16fdf2dee8bf51e860db307e96262f5e669e2f3d34b166f0b5cd83f9b5b36018efc4de8e45e1265964919b24ac85b1a
+DIST openafs-patches-20160713.tar.xz 11020 SHA256 28706a396cf106ee83a81e252587f877cbcee1d066e8039645c47032ff7c6254 SHA512 4c6c66bf3ae79e32c5d70e9c605f601c3fe38a967e43f84ed4e0e6a6481cbfc3f863a0870a42705fb37fc393ee85029e91e25cb42cb4c8712f8540e4088429fd WHIRLPOOL 4e7ebf8f51219138c6786d3f93e9e42cd1f1501542713ba07143ae3b999326d37e32dc3e0ef99db5d612fd3a9ad7c38add83b3e649e36a67b767db1060943f78
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.6.18.2.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.6.18.2.ebuild
new file mode 100644
index 000000000000..c2ab02f63ab3
--- /dev/null
+++ b/net-fs/openafs-kernel/openafs-kernel-1.6.18.2.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools linux-mod multilib toolchain-funcs versionator
+
+MY_PV=$(delete_version_separator '_')
+MY_PN="${PN/-kernel}"
+MY_P="${MY_PN}-${MY_PV}"
+PVER="20160713"
+
+DESCRIPTION="The OpenAFS distributed file system kernel module"
+HOMEPAGE="https://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+[[ ${PV} == *_pre* ]] && MY_PRE="candidate/" || MY_PRE=""
+SRC_URI="
+ https://openafs.org/dl/openafs/${MY_PRE}${MY_PV}/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~bircoph/afs/${MY_PN}-patches-${PVER}.tar.xz
+"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="~!AFS_FS KEYS"
+ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
+ERROR_KEYS="OpenAFS needs CONFIG_KEYS option enabled"
+
+QA_TEXTRELS_x86_fbsd="/boot/modules/libafs.ko"
+QA_TEXTRELS_amd64_fbsd="/boot/modules/libafs.ko"
+
+PATCHES=( "${WORKDIR}/gentoo/patches" )
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is ge 4 7 ; then
+ ewarn "Gentoo supports kernels which are supported by OpenAFS"
+ ewarn "which are limited to the kernel versions: < 4.5"
+ ewarn ""
+ ewarn "You are free to utilize epatch_user to provide whatever"
+ ewarn "support you feel is appropriate, but will not receive"
+ ewarn "support as a result of those changes."
+ ewarn ""
+ ewarn "Please do not file a bug report about this."
+ fi
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ linux-mod_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ # packaging is f-ed up, so we can't run eautoreconf
+ # run autotools commands based on what is listed in regen.sh
+ eaclocal -I src/cf
+ eautoconf
+ eautoconf -o configure-libafs configure-libafs.ac
+ eautoheader
+ einfo "Deleting autom4te.cache directory"
+ rm -rf autom4te.cache
+}
+
+src_configure() {
+ local myconf=""
+ # OpenAFS 1.6.11 has a bug with kernels 3.17-3.17.2 that requires a config option
+ if use kernel_linux && kernel_is -ge 3 17 && kernel_is -le 3 17 2; then
+ myconf="--enable-linux-d_splice_alias-extra-iput"
+ fi
+
+ local ARCH="$(tc-arch-kernel)"
+ local MY_ARCH="$(tc-arch)"
+ local BSD_BUILD_DIR="/usr/src/sys/${MY_ARCH}/compile/GENERIC"
+
+ if use kernel_linux; then
+ myconf+=( --with-linux-kernel-headers="${KV_DIR}" \
+ --with-linux-kernel-build="${KV_OUT_DIR}"
+ )
+ elif use kernel_FreeBSD; then
+ myconf+=( --with-bsd-kernel-build="${BSD_BUILD_DIR}" )
+ fi
+ econf \
+ $(use_enable debug debug-kernel) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ ARCH="$(tc-arch-kernel)" AR="$(tc-getAR)" emake V=1 -j1 only_libafs
+}
+
+src_install() {
+ if use kernel_linux; then
+ local srcdir=$(expr "${S}"/src/libafs/MODLOAD-*)
+ [[ -f ${srcdir}/libafs.${KV_OBJ} ]] || die "Couldn't find compiled kernel module"
+
+ MODULE_NAMES="libafs(fs/openafs:${srcdir})"
+
+ linux-mod_src_install
+ elif use kernel_FreeBSD; then
+ insinto /boot/modules
+ doins "${S}"/src/libafs/MODLOAD/libafs.ko
+ fi
+}
+
+pkg_postinst() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+ use kernel_linux && linux-mod_pkg_postinst
+
+ if use kernel_linux && [[ ${REPLACING_VERSIONS} < "1.6.18.2" ]]; then
+ ewarn "As of OpenAFS 1.6.18.2, Gentoo's packaging no longer requires"
+ ewarn "that CONFIG_DEBUG_RODATA be turned off in one's kernel config."
+ ewarn "If you only turned this option off for OpenAFS, please re-enable"
+ ewarn "it, as keeping it turned off is a security risk."
+ fi
+}
+
+pkg_postrm() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+ use kernel_linux && linux-mod_pkg_postrm
+}