summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-12 07:57:18 +0100
committerSam James <sam@gentoo.org>2022-04-12 07:57:18 +0100
commitd092dfd7485f030626d55087e004e3996f0986e4 (patch)
tree1e699c32d631d52b57424d1194c450bb8c4b7984 /net-fs
parentsys-apps/coreutils: test fixes & rebase patchset (diff)
downloadgentoo-d092dfd7485f030626d55087e004e3996f0986e4.tar.gz
gentoo-d092dfd7485f030626d55087e004e3996f0986e4.tar.bz2
gentoo-d092dfd7485f030626d55087e004e3996f0986e4.zip
net-fs/samba: fix race condition during build
It's a bit gross but no different from having to force -j1 if upstream clearly aren't testing w/ it. Upstream force PYTHONHASHSEED=1 (which gives determinism) in their builds, so we need to as well, to avoid confusing failures. Closes: https://bugs.gentoo.org/836167 Acked-by: David Seifert <soap@gentoo.org> Thanks-to: Marien Zwart <marien.zwart@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-4.15.6.ebuild6
-rw-r--r--net-fs/samba/samba-4.16.0.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/net-fs/samba/samba-4.15.6.ebuild b/net-fs/samba/samba-4.15.6.ebuild
index 2d8b250202b8..fc12bd068d9e 100644
--- a/net-fs/samba/samba-4.15.6.ebuild
+++ b/net-fs/samba/samba-4.15.6.ebuild
@@ -249,16 +249,16 @@ multilib_src_configure() {
myconf+=( --with-shared-modules=DEFAULT,!vfs_snapper )
fi
- CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
+ PYTHONHASHSEED=1 CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
waf-utils_src_configure ${myconf[@]}
}
multilib_src_compile() {
- waf-utils_src_compile
+ PYTHONHASHSEED=1 waf-utils_src_compile
}
multilib_src_install() {
- waf-utils_src_install
+ PYTHONHASHSEED=1 waf-utils_src_install
# Make all .so files executable
find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
diff --git a/net-fs/samba/samba-4.16.0.ebuild b/net-fs/samba/samba-4.16.0.ebuild
index acbdab767d9f..54d617f29c82 100644
--- a/net-fs/samba/samba-4.16.0.ebuild
+++ b/net-fs/samba/samba-4.16.0.ebuild
@@ -250,16 +250,16 @@ multilib_src_configure() {
myconf+=( --with-shared-modules=DEFAULT,!vfs_snapper )
fi
- CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
+ PYTHONHASHSEED=1 CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
waf-utils_src_configure ${myconf[@]}
}
multilib_src_compile() {
- waf-utils_src_compile
+ PYTHONHASHSEED=1 waf-utils_src_compile
}
multilib_src_install() {
- waf-utils_src_install
+ PYTHONHASHSEED=1 waf-utils_src_install
# Make all .so files executable
find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die