summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2020-02-16 13:46:28 +0100
committerTobias Klausmann <klausman@gentoo.org>2020-02-16 13:46:28 +0100
commitb31081eeb6c2b2ea7d22f79ff10710dab6400a0c (patch)
tree966c9663043454585bfabd788e08110f85290a09 /net-ftp/atftp/atftp-0.7.2-r1.ebuild
parentdev-python/aiorpcX: Bump to 0.18.4, add tests (diff)
downloadgentoo-b31081eeb6c2b2ea7d22f79ff10710dab6400a0c.tar.gz
gentoo-b31081eeb6c2b2ea7d22f79ff10710dab6400a0c.tar.bz2
gentoo-b31081eeb6c2b2ea7d22f79ff10710dab6400a0c.zip
net-ftp/atftp: Clean up deps and remove old
This drops the superfluous netkit-tftp blocker, removes unnecessary +x bit on the init script and removes the old version 0.7-r6. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'net-ftp/atftp/atftp-0.7.2-r1.ebuild')
-rw-r--r--net-ftp/atftp/atftp-0.7.2-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-ftp/atftp/atftp-0.7.2-r1.ebuild b/net-ftp/atftp/atftp-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..5a2c3723d44a
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7.2-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="https://sourceforge.net/projects/atftp/"
+SRC_URI="mirror://sourceforge/atftp/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ readline? ( sys-libs/readline:0= )
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}
+ !net-ftp/tftp-hpa
+ !net-ftp/uftpd
+ selinux? ( sec-policy/selinux-tftp )"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-CFLAGS.patch"
+)
+
+src_prepare() {
+ append-cppflags -D_REENTRANT -DRATE_CONTROL
+ # fix #561720 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp
+}
+
+src_test() {
+ cd "${S}"/test || die
+ # Try to run the tests
+ ./test.sh || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ systemd_dounit "${FILESDIR}"/atftp.service
+ systemd_install_serviced "${FILESDIR}"/atftp.service.conf
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc "${S}"/docs/*
+
+ docinto test
+ cd "${S}"/test || die
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}