summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2020-09-04 09:46:51 +0200
committerSam James <sam@gentoo.org>2020-09-29 20:37:13 +0000
commit11e7e99ea634c63e2eb84141537d815f174e5fc5 (patch)
treea62a23eb0443b02777695f3afbd137167937296c /net-ftp/uftpd/uftpd-2.13.ebuild
parentnet-ftp/tftp-hpa: fix collision with uftpd (diff)
downloadgentoo-11e7e99ea634c63e2eb84141537d815f174e5fc5.tar.gz
gentoo-11e7e99ea634c63e2eb84141537d815f174e5fc5.tar.bz2
gentoo-11e7e99ea634c63e2eb84141537d815f174e5fc5.zip
net-ftp/uftpd: fix failing tests
Now that tftp-hpa is split to and client server, one can install only the client to run the tests. Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-ftp/uftpd/uftpd-2.13.ebuild')
-rw-r--r--net-ftp/uftpd/uftpd-2.13.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/net-ftp/uftpd/uftpd-2.13.ebuild b/net-ftp/uftpd/uftpd-2.13.ebuild
index fc8503685308..d2c9e2b701b4 100644
--- a/net-ftp/uftpd/uftpd-2.13.ebuild
+++ b/net-ftp/uftpd/uftpd-2.13.ebuild
@@ -9,14 +9,26 @@ SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="
+RDEPEND="
>=dev-libs/libite-1.5
>=dev-libs/libuev-2.2"
-RDEPEND="
- ${DEPEND}
+DEPEND="
+ ${RDEPEND}
!net-misc/uftp
- !net-ftp/atftp"
+ !net-ftp/atftp
+ !net-ftp/tftp-hpa[server]
+ test? (
+ net-ftp/ftp
+ net-ftp/tnftp
+ net-ftp/tftp-hpa[client]
+ )"
+
+src_test() {
+ # can't run the tests in parallel since the order matters
+ emake -j 1 check
+}