summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-02-02 10:24:40 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-02 15:06:31 +0200
commit62ed671b337aa94c1ec37d5a0a86e9bb38e81672 (patch)
treec0269d741cd537e5d5314e0c1ee2d363c3500e46 /net-ftp
parentnet-im/telegram-desktop-bin: cleanup old (diff)
downloadgentoo-62ed671b337aa94c1ec37d5a0a86e9bb38e81672.tar.gz
gentoo-62ed671b337aa94c1ec37d5a0a86e9bb38e81672.tar.bz2
gentoo-62ed671b337aa94c1ec37d5a0a86e9bb38e81672.zip
net-ftp/atftp: version bump to 0.7.4
new version fixes security issues upstream fix self-testing script test.sh fix compile against sys-libs/musl Closes: https://bugs.gentoo.org/713672 Closes: https://bugs.gentoo.org/687536 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/19302 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/atftp/Manifest1
-rw-r--r--net-ftp/atftp/atftp-0.7.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-ftp/atftp/Manifest b/net-ftp/atftp/Manifest
index eccbf7737c89..0784eea0d364 100644
--- a/net-ftp/atftp/Manifest
+++ b/net-ftp/atftp/Manifest
@@ -1 +1,2 @@
DIST atftp-0.7.2.tar.gz 248038 BLAKE2B 3ca44624bf989009c2ebd0ae97927b0784e3c617a79a1bd00212a72a185302cf84f51c8bcda2012981d67cfed4d241b70f8719e78155207608f07a2227e6c437 SHA512 d602bb69451175a36e619abcff412ab1f6d0e7baf8c3f9a2b32081530fbc5816157404b80d42a8b6caa89cc83675b5cbeefcd57a5d98b8f5b43c6254b20ef28b
+DIST atftp-0.7.4.tar.gz 249699 BLAKE2B 8aa30df1cc92982b0e718cd9bcc68cf397e29f6abb795cf9fdfd0b9942d9a7dd16beafb24d69d7339f9ab4cbda16404eadf40096a8dfdb684fbc7ec1c7f81c9f SHA512 f9ff9b72b7d1d659d4ca00d990c28b9da8dea0228e66610ee2d17a3959fcd142998a7539f8ea68effdfe830d2f5e68c154a2911afb9cad52acd24a6a642d76a4
diff --git a/net-ftp/atftp/atftp-0.7.4.ebuild b/net-ftp/atftp/atftp-0.7.4.ebuild
new file mode 100644
index 000000000000..1a1fe73e17ea
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="https://sourceforge.net/projects/atftp/"
+SRC_URI="mirror://sourceforge/atftp/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ readline? ( sys-libs/readline:0= )
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}
+ !net-ftp/tftp-hpa
+ !net-ftp/uftpd
+ selinux? ( sec-policy/selinux-tftp )"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/atftp-0.7.2-CFLAGS.patch"
+)
+
+src_prepare() {
+ append-cppflags -D_REENTRANT -DRATE_CONTROL
+ # fix #561720 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp
+}
+
+src_test() {
+ cd "${S}"/test || die
+ TEMPDIR=. ./test.sh || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ systemd_dounit "${FILESDIR}"/atftp.service
+ systemd_install_serviced "${FILESDIR}"/atftp.service.conf
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc "${S}"/docs/*
+
+ docinto test
+ cd "${S}"/test || die
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}