summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-12-10 10:43:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-03-07 10:27:43 +0200
commit6fe4fd145a4eae9dfbe551963b2594f310d8027e (patch)
treedd9cdf51c9300b181bedabea8c5e832aee36393b /net-ftp
parentwww-apps/hugo: drop 0.108.0, 0.110.0 (diff)
downloadgentoo-6fe4fd145a4eae9dfbe551963b2594f310d8027e.tar.gz
gentoo-6fe4fd145a4eae9dfbe551963b2594f310d8027e.tar.bz2
gentoo-6fe4fd145a4eae9dfbe551963b2594f310d8027e.zip
net-ftp/yafc: fix build for clang16
- add new homepage - patch autoreconf - runs eautoreconf in ebuild Closes: https://bugs.gentoo.org/731160 Closes: https://bugs.gentoo.org/783381 Closes: https://bugs.gentoo.org/831240 Closes: https://bugs.gentoo.org/882231 Closes: https://bugs.gentoo.org/885289 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/28624 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/yafc/Manifest1
-rw-r--r--net-ftp/yafc/files/yafc-1.3.7-fix-autoreconf.patch15
-rw-r--r--net-ftp/yafc/metadata.xml3
-rw-r--r--net-ftp/yafc/yafc-1.3.7-r2.ebuild58
4 files changed, 77 insertions, 0 deletions
diff --git a/net-ftp/yafc/Manifest b/net-ftp/yafc/Manifest
index db0866715c1d..a1dc2ee3f4c1 100644
--- a/net-ftp/yafc/Manifest
+++ b/net-ftp/yafc/Manifest
@@ -1 +1,2 @@
+DIST yafc-1.3.7.tar.gz 237011 BLAKE2B 0a74ff408c52fb35ac5f2e4738bfb7480b3de2339a0c0d1b67534736926c202ad4dbe1dd875c0b84aaa07ca844e24629e3b030daddb392f419fdbd377d4d7b6f SHA512 820a0de1073f3340e36480dfb43908314200f00046762ed1e2735963ea25a541ea0b6b1b662a16117d2a3ce1e235554d7673c989f25a1b97d362028db5986f3f
DIST yafc-1.3.7.tar.xz 363692 BLAKE2B deeda22d997ee7f3dd04626cdac352ec43f5e47c66029d59f474c43f7ccfba4ed8cbf886fc6ac7a684b8828d30baa02ee880978c891c34337607d88a42582db1 SHA512 2547cf3d6f1918a5cd2d3bc29455311d48fcd7dbccfdc8ae4ce08d1fd63cfabae07b70ebf005206a61937bd5b686e19d3af095f876616a5ac4b0593e90cd39c5
diff --git a/net-ftp/yafc/files/yafc-1.3.7-fix-autoreconf.patch b/net-ftp/yafc/files/yafc-1.3.7-fix-autoreconf.patch
new file mode 100644
index 000000000000..d59e8be4a1b1
--- /dev/null
+++ b/net-ftp/yafc/files/yafc-1.3.7-fix-autoreconf.patch
@@ -0,0 +1,15 @@
+Pascal Jäger <pascal.jaeger@leimstift.de> (2022-12-10)
+
+--- a/m4/glib-gettext.m4
++++ b/m4/glib-gettext.m4
+@@ -36,8 +36,8 @@ dnl We go to great lengths to make sure that aclocal won't
+ dnl try to pull in the installed version of these macros
+ dnl when running aclocal in the glib directory.
+ dnl
+-m4_copy([AC_DEFUN],[glib_DEFUN])
+-m4_copy([AC_REQUIRE],[glib_REQUIRE])
++m4_copy_force([AC_DEFUN],[glib_DEFUN])
++m4_copy_force([AC_REQUIRE],[glib_REQUIRE])
+ dnl
+ dnl At the end, if we're not within glib, we'll define the public
+ dnl definitions in terms of our private definitions.
diff --git a/net-ftp/yafc/metadata.xml b/net-ftp/yafc/metadata.xml
index aa60338523ea..b895d8d8fc10 100644
--- a/net-ftp/yafc/metadata.xml
+++ b/net-ftp/yafc/metadata.xml
@@ -5,4 +5,7 @@
<use>
<flag name="ssh">Build with SFTP support</flag>
</use>
+ <upstream>
+ <remote-id type="github">sebastinas/yafc</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-ftp/yafc/yafc-1.3.7-r2.ebuild b/net-ftp/yafc/yafc-1.3.7-r2.ebuild
new file mode 100644
index 000000000000..4ee1bb082764
--- /dev/null
+++ b/net-ftp/yafc/yafc-1.3.7-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="Console ftp client with a lot of nifty features"
+HOMEPAGE="https://github.com/sebastinas/yafc"
+SRC_URI="https://github.com/sebastinas/yafc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="kerberos readline socks5 ssh"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ dev-libs/libbsd
+ dev-libs/openssl:0=
+ kerberos? ( virtual/krb5 )
+ readline? ( >=sys-libs/readline-6:0= )
+ socks5? ( net-proxy/dante )
+ ssh? ( net-libs/libssh )
+"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/gettext
+ sys-apps/texinfo
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( BUGS NEWS README.md THANKS TODO )
+
+PATCHES=( "${FILESDIR}/${P}-fix-autoreconf.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_ipv6=yes
+ local myeconfargs=(
+ $(use_with readline readline /usr)
+ $(use_with socks5 socks /usr)
+ $(use_with socks5 socks5 /usr)
+ $(use_with kerberos krb5)
+ $(use_with ssh)
+ --with-bash-completion="$(get_bashcompdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc -r samples
+}