summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-06-02 17:41:10 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-06-02 17:41:10 +0200
commitec7e8721225a0286aabeaa04cf6b8ce9960d4745 (patch)
treefae53121de1bca88902fb65902b03b891b031b57 /net-ftp
parentx11-terms/kitty: stabilize 0.25.1 for amd64, x86 (diff)
downloadgentoo-ec7e8721225a0286aabeaa04cf6b8ce9960d4745.tar.gz
gentoo-ec7e8721225a0286aabeaa04cf6b8ce9960d4745.tar.bz2
gentoo-ec7e8721225a0286aabeaa04cf6b8ce9960d4745.zip
net-ftp/filezilla: add 3.60.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.60.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index b3eab08cd4a2..5a40ade11417 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -1,2 +1,3 @@
DIST FileZilla_3.58.0_src.tar.bz2 4931087 BLAKE2B c0a9ed0d14a9cbc0d392f9680c4c6c60cb4157ec87be596aa8c7edb53dff23ed21ccb234b58a32b9929cb44f1624dfc8c0a3d09690be467bdeef6ebba802b354 SHA512 f613f210d9176be2dd41046ecdf4598604f8902829edfe5981564217561417ca35029618b0c50cdb6232220ec0440bd390f098b602c05845c846efe0689d9d54
DIST FileZilla_3.59.0_src.tar.bz2 4946231 BLAKE2B db8651490444aed547c7e26eaa8b13a1920ba4fcf6e0343ddbc021861db44f750aa4cf537c943d895110ee2b7b2a72f17f060198d3d16a0ceaf9642db87ce50d SHA512 063de23e7b529ee7422479ebb1af00ab86a82ee25cf0e7e1e06995bf897aeeb25aab161ab202de889ea750c796a0ac1317c5a08dcb89fa1f4cbdb79caa3cbfc7
+DIST FileZilla_3.60.1_src.tar.bz2 4954184 BLAKE2B 94a2d95729e2e540a3ff6ed1b9ed8fc5f4ccb96eb1e4edae655476b5d099c489ecb0ed58c26cab2df97518c9ab4f7058af1f4633fead924dcb400909e1913eeb SHA512 417b97afd8e9434c625392c4025ab7d977d58fad2dfe17c8ff856233c70b5d77df22c4e1b76120d9d5dba3bce1c61453808deb26314dbde7ec425d643c4f83d9
diff --git a/net-ftp/filezilla/filezilla-3.60.1.ebuild b/net-ftp/filezilla/filezilla-3.60.1.ebuild
new file mode 100644
index 000000000000..1a1a0c69c8f1
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.60.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets xdg
+
+MY_PV="${PV/_/-}"
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="dbus nls test"
+RESTRICT="!test? ( test )"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND="
+ >=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.37.1:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cppunit-1.13.0 )"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+ "${FILESDIR}"/${PN}-3.52.2-slibtool.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}