summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-27 23:26:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 03:53:17 +0200
commitc98875e1bcd07b1ac1d4d29be4208711de0b4ea7 (patch)
tree394cca965858dfb1986720cfdb0c0ef6409bcf95 /net-im/choqok/choqok-1.6.0_p20190726.ebuild
parentapp-editors/kile: kile-2.9.92_p20190716 snapshot bump, EAPI-7 (diff)
downloadgentoo-c98875e1bcd07b1ac1d4d29be4208711de0b4ea7.tar.gz
gentoo-c98875e1bcd07b1ac1d4d29be4208711de0b4ea7.tar.bz2
gentoo-c98875e1bcd07b1ac1d4d29be4208711de0b4ea7.zip
net-im/choqok: 1.6.0_p20190726 snapshot bump, EAPI-7
Contains fetched translations and handbook using upstream's tarme.rb Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/choqok/choqok-1.6.0_p20190726.ebuild')
-rw-r--r--net-im/choqok/choqok-1.6.0_p20190726.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-im/choqok/choqok-1.6.0_p20190726.ebuild b/net-im/choqok/choqok-1.6.0_p20190726.ebuild
new file mode 100644
index 000000000000..a24edf12236e
--- /dev/null
+++ b/net-im/choqok/choqok-1.6.0_p20190726.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Free/Open Source micro-blogging client by KDE"
+HOMEPAGE="https://choqok.kde.org/"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="attica konqueror telepathy"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetworkauth)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ app-crypt/qca[qt5(+)]
+ attica? ( $(add_frameworks_dep attica) )
+ konqueror? (
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kdewebkit)
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
+ )
+ telepathy? ( net-libs/telepathy-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package attica KF5Attica)
+ $(cmake-utils_use_find_package konqueror KF5Parts)
+ $(cmake-utils_use_find_package konqueror KF5WebKit)
+ $(cmake-utils_use_find_package telepathy TelepathyQt5)
+ )
+
+ kde5_src_configure
+}