summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-19 03:41:36 +0000
committerSam James <sam@gentoo.org>2022-05-19 03:41:36 +0000
commit23af4fed2d7cc961e7df0ccb0765e590e673f9ab (patch)
tree34655cd5cb3581973970707dddbeff09b44089e2 /net-im/coturn/coturn-9999.ebuild
parentsys-process/criu: add 3.17 (diff)
downloadgentoo-23af4fed2d7cc961e7df0ccb0765e590e673f9ab.tar.gz
gentoo-23af4fed2d7cc961e7df0ccb0765e590e673f9ab.tar.bz2
gentoo-23af4fed2d7cc961e7df0ccb0765e590e673f9ab.zip
net-im/coturn: fix automagic OpenSSL dep
Also: - Fix calling AR, CC directly - Fix TMPDIR usage Bug: https://bugs.gentoo.org/729820 Closes: https://bugs.gentoo.org/835652 Closes: https://bugs.gentoo.org/724918 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/coturn/coturn-9999.ebuild')
-rw-r--r--net-im/coturn/coturn-9999.ebuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/net-im/coturn/coturn-9999.ebuild b/net-im/coturn/coturn-9999.ebuild
index 4f65686782b4..d3a3c8813604 100644
--- a/net-im/coturn/coturn-9999.ebuild
+++ b/net-im/coturn/coturn-9999.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd tmpfiles
+
+inherit toolchain-funcs systemd tmpfiles
DESCRIPTION="coturn TURN server project"
HOMEPAGE="https://github.com/coturn/coturn"
if [ ${PV} = 9999 ]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
inherit git-r3
- DEPEND="dev-vcs/git"
# S="${WORKDIR}/${PN}-master"
else
KEYWORDS="~amd64 ~x86"
@@ -20,15 +20,20 @@ LICENSE="BSD"
SLOT="0"
IUSE="mongodb mysql postgres redis sqlite"
RDEPEND="acct-group/turnserver
- acct-user/turnserver
- >dev-libs/libevent-2.1.8:=
- mongodb? ( dev-libs/mongo-c-driver )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:* )
- redis? ( dev-libs/hiredis:= )
- sqlite? ( dev-db/sqlite )"
-
+ acct-user/turnserver
+ >dev-libs/libevent-2.1.8:=
+ dev-libs/openssl:=
+ mongodb? ( dev-libs/mongo-c-driver )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:* )
+ redis? ( dev-libs/hiredis:= )
+ sqlite? ( dev-db/sqlite )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.2-respect-TMPDIR.patch
+)
src_configure() {
if [ -n "${AR}" ]; then
@@ -56,7 +61,13 @@ src_configure() {
if ! use sqlite; then
export TURN_NO_SQLITE=yes
fi
+
+ tc-export CC
+
+ export ARCHIVERCMD="$(tc-getAR) -r"
+ export PKGCONFIG="$(tc-getPKG_CONFIG)"
export DOCSDIR="/usr/share/doc/${PN}-${PV}"
+
econf $(use_with sqlite)
}