summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-30 13:10:57 +0200
committerDavid Seifert <soap@gentoo.org>2023-03-30 13:10:57 +0200
commit037f1d9154f8f27f5bee08bd8c240e312dd82bdc (patch)
tree994168e38d80ab6b0c557eae10cd63cfcd563ba0 /net-im/ekg2/ekg2-9999.ebuild
parentsys-power/dptfxtract: treeclean (diff)
downloadgentoo-037f1d9154f8f27f5bee08bd8c240e312dd82bdc.tar.gz
gentoo-037f1d9154f8f27f5bee08bd8c240e312dd82bdc.tar.bz2
gentoo-037f1d9154f8f27f5bee08bd8c240e312dd82bdc.zip
net-im/ekg2: treeclean
Closes: https://bugs.gentoo.org/885713 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-im/ekg2/ekg2-9999.ebuild')
-rw-r--r--net-im/ekg2/ekg2-9999.ebuild104
1 files changed, 0 insertions, 104 deletions
diff --git a/net-im/ekg2/ekg2-9999.ebuild b/net-im/ekg2/ekg2-9999.ebuild
deleted file mode 100644
index 3243fa4af2fd..000000000000
--- a/net-im/ekg2/ekg2-9999.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools git-r3
-
-DESCRIPTION="Text-based, multi-protocol instant messenger"
-HOMEPAGE="https://github.com/ekg2/ekg2/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/ekg2/${PN}.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="gadu gpm gpg gtk minimal ncurses nls nntp openssl
- perl readline rss spell sqlite ssl xmpp unicode zlib"
-
-RDEPEND="dev-libs/glib:2
- gadu? ( <net-libs/libgadu-1.12:0= )
- gpg? ( app-crypt/gpgme:= )
- gtk? ( x11-libs/gtk+:2 )
- nls? ( virtual/libintl:0= )
- openssl? ( dev-libs/openssl:0= )
- perl? ( dev-lang/perl:0= )
- readline? ( sys-libs/readline:0= )
- rss? ( dev-libs/expat:0= )
- ssl? ( net-libs/gnutls:0= )
- xmpp? ( dev-libs/expat:0= )
- zlib? ( sys-libs/zlib:0= )
-
- ncurses? ( sys-libs/ncurses:=[unicode(+)=]
- gpm? ( sys-libs/gpm:0= )
- spell? ( app-text/aspell:0= ) )
- sqlite? ( dev-db/sqlite:3= )"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext"
-
-DOCS=(
- AUTHORS README.md docs/README docs/TODO
- docs/events.txt docs/mouse.txt docs/sim.txt docs/voip.txt
- docs/themes.txt docs/themes-en.txt
- docs/ui-ncurses.txt docs/ui-ncurses-en.txt
-)
-
-pkg_pretend() {
- if ! use gtk && ! use ncurses && ! use readline; then
- ewarn 'ekg2 is being compiled without any frontend. You should consider'
- ewarn 'enabling at least one of following USEflags:'
- ewarn ' gtk, ncurses, readline.'
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- # direct plugin references
- $(use_enable gadu gg)
- $(use_enable gpg)
- $(use_enable gtk)
- $(use_enable ncurses)
- $(use_enable nntp)
- $(use_enable openssl sim)
- $(use_enable perl)
- --disable-python
- $(use_enable readline)
- $(use_enable rss)
- $(use_enable sqlite logsqlite)
- $(use_enable xmpp jabber)
-
- $(use_enable !minimal autoresponder)
- $(use_enable !minimal jogger)
- $(use_enable !minimal mail)
- $(use_enable !minimal polchat)
- $(use_enable !minimal rivchat)
- $(use_enable !minimal sms)
-
- # sqlite switch
- --with-sqlite3
-
- # optional deps
- $(use_with gpm)
- # do not pass --with-inotify as it will fail if check fails
- $(use_with spell aspell)
- $(use_with ssl gnutls)
- $(use_with zlib)
-
- # other magic
- $(use_enable nls)
- --with-perl-module-build-flags='INSTALLDIRS=vendor'
- --enable-fast-configure
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}