summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-09 16:04:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-09 17:17:48 +0200
commitb4a5d59dcba12a0a628269689b0e61dd9de2d319 (patch)
tree5eb18bc4cabb1c4da8f340fa79d456cdb080b43c /net-im/pidgin/files
parentsystemd.eclass: deprecate tmpfiles functions (diff)
downloadgentoo-b4a5d59dcba12a0a628269689b0e61dd9de2d319.tar.gz
gentoo-b4a5d59dcba12a0a628269689b0e61dd9de2d319.tar.bz2
gentoo-b4a5d59dcba12a0a628269689b0e61dd9de2d319.zip
net-im/pidgin: Removed old
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-im/pidgin/files')
-rw-r--r--net-im/pidgin/files/pidgin-2.10.0-gold.patch30
-rw-r--r--net-im/pidgin/files/pidgin-2.13.0-fix-build-against-nm-1.0.patch54
-rw-r--r--net-im/pidgin/files/pidgin-2.13.0-gnutls_sni_support.patch33
-rw-r--r--net-im/pidgin/files/pidgin-2.13.0-python3_support.patch37
4 files changed, 0 insertions, 154 deletions
diff --git a/net-im/pidgin/files/pidgin-2.10.0-gold.patch b/net-im/pidgin/files/pidgin-2.10.0-gold.patch
deleted file mode 100644
index 819bfdc5c6bf..000000000000
--- a/net-im/pidgin/files/pidgin-2.10.0-gold.patch
+++ /dev/null
@@ -1,30 +0,0 @@
- pidgin/Makefile.am | 2 +-
- pidgin/Makefile.in | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/pidgin/Makefile.am b/pidgin/Makefile.am
-index b6a5bd4..96d207d 100644
---- a/pidgin/Makefile.am
-+++ b/pidgin/Makefile.am
-@@ -158,7 +158,7 @@ pidgin_LDADD = \
- $(GTKSPELL_LIBS) \
- $(LIBXML_LIBS) \
- $(GTK_LIBS) \
-- $(top_builddir)/libpurple/libpurple.la
-+ $(top_builddir)/libpurple/libpurple.la -lm
-
- if USE_INTERNAL_LIBGADU
- INTGG_CFLAGS = -DUSE_INTERNAL_LIBGADU
-diff --git a/pidgin/Makefile.in b/pidgin/Makefile.in
-index 615c196..0293e5c 100644
---- a/pidgin/Makefile.in
-+++ b/pidgin/Makefile.in
-@@ -607,7 +607,7 @@ EXTRA_DIST = \
- @ENABLE_GTK_TRUE@ $(GTKSPELL_LIBS) \
- @ENABLE_GTK_TRUE@ $(LIBXML_LIBS) \
- @ENABLE_GTK_TRUE@ $(GTK_LIBS) \
--@ENABLE_GTK_TRUE@ $(top_builddir)/libpurple/libpurple.la
-+@ENABLE_GTK_TRUE@ $(top_builddir)/libpurple/libpurple.la -lm
-
- @ENABLE_GTK_TRUE@@USE_INTERNAL_LIBGADU_TRUE@INTGG_CFLAGS = -DUSE_INTERNAL_LIBGADU
- @ENABLE_GTK_TRUE@AM_CPPFLAGS = \
diff --git a/net-im/pidgin/files/pidgin-2.13.0-fix-build-against-nm-1.0.patch b/net-im/pidgin/files/pidgin-2.13.0-fix-build-against-nm-1.0.patch
deleted file mode 100644
index d9d27930439c..000000000000
--- a/net-im/pidgin/files/pidgin-2.13.0-fix-build-against-nm-1.0.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://src.fedoraproject.org/rpms/pidgin/raw/master/f/pidgin-2.13.0-fix-build-against-nm-1.0.patch
-
-diff --git a/configure.ac b/configure.ac
-index 04836fa..0a2d451 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1423,18 +1423,24 @@ fi
- dnl Check for NetworkManager.h; if we don't have it, oh well
- if test "x$enable_dbus" = "xyes" ; then
- if test "x$enable_nm" = "xyes" ; then
-- PKG_CHECK_MODULES(NETWORKMANAGER, [NetworkManager >= 0.5.0], [
-+ PKG_CHECK_MODULES(NETWORKMANAGER, [libnm], [
- AC_SUBST(NETWORKMANAGER_CFLAGS)
- AC_SUBST(NETWORKMANAGER_LIBS)
- AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
- ], [
-- enable_nm=no
-- if test "x$force_deps" = "xyes" ; then
-- AC_MSG_ERROR([
-+ PKG_CHECK_MODULES(NETWORKMANAGER, [NetworkManager >= 0.5.0], [
-+ AC_SUBST(NETWORKMANAGER_CFLAGS)
-+ AC_SUBST(NETWORKMANAGER_LIBS)
-+ AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
-+ ], [
-+ enable_nm=no
-+ if test "x$force_deps" = "xyes" ; then
-+ AC_MSG_ERROR([
- NetworkManager development headers not found.
- Use --disable-nm if you do not need NetworkManager support.
- ])
-- fi])
-+ fi])
-+ ])
- fi
- else
- enable_nm=no
-diff --git a/libpurple/network.c b/libpurple/network.c
-index c43e3c7..b17e439 100644
---- a/libpurple/network.c
-+++ b/libpurple/network.c
-@@ -939,8 +939,13 @@ nm_update_state(NMState state)
- #if NM_CHECK_VERSION(0,8,992)
- case NM_STATE_DISCONNECTING:
- #endif
-+#if NM_CHECK_VERSION(1,0,0)
-+ if (prev != NM_STATE_CONNECTED_GLOBAL && prev != NM_STATE_UNKNOWN)
-+ break;
-+#else
- if (prev != NM_STATE_CONNECTED && prev != NM_STATE_UNKNOWN)
- break;
-+#endif
- if (ui_ops != NULL && ui_ops->network_disconnected != NULL)
- ui_ops->network_disconnected();
- break;
diff --git a/net-im/pidgin/files/pidgin-2.13.0-gnutls_sni_support.patch b/net-im/pidgin/files/pidgin-2.13.0-gnutls_sni_support.patch
deleted file mode 100644
index df6b8e5cd030..000000000000
--- a/net-im/pidgin/files/pidgin-2.13.0-gnutls_sni_support.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-# HG changeset patch
-# User Mihai Moldovan <ionic@ionic.de>
-# Date 1576498301 -3600
-# Branch release-2.x.y
-# Node ID 6dba8046e1b120c506e1d911c6aa8757d7774c57
-# Parent 7a975763d3b64bdd8dd5371d711a4add647ed726
-Implement SNI support for the gnutls SSL plugin.
-
-Note that gnutls is picky in regard to what it accepts as the server name - it
-MUST be a domain name. IP addresses are not supported according to the
-documentation.
-
-Hence, filter out IP addresses and hope that whatever is not recognized as
-such an address is actually a domain name. This will probably fail for more
-exotic addresses (especially in IPv6 realm), but wiring up a full-blown parser
-is too much effort and SSL plugins are not part of purple-3 anyway.
-
-Fixes #17300
-
-diff --git a/libpurple/plugins/ssl/ssl-gnutls.c b/libpurple/plugins/ssl/ssl-gnutls.c
---- a/libpurple/plugins/ssl/ssl-gnutls.c
-+++ b/libpurple/plugins/ssl/ssl-gnutls.c
-@@ -403,6 +403,10 @@
-
- gnutls_transport_set_ptr(gnutls_data->session, GINT_TO_POINTER(gsc->fd));
-
-+ /* SNI support. */
-+ if (gsc->host && !g_hostname_is_ip_address(gsc->host))
-+ gnutls_server_name_set(gnutls_data->session, GNUTLS_NAME_DNS, gsc->host, strlen(gsc->host));
-+
- gnutls_data->handshake_handler = purple_input_add(gsc->fd,
- PURPLE_INPUT_READ, ssl_gnutls_handshake_cb, gsc);
-
diff --git a/net-im/pidgin/files/pidgin-2.13.0-python3_support.patch b/net-im/pidgin/files/pidgin-2.13.0-python3_support.patch
deleted file mode 100644
index 19ece4a9a223..000000000000
--- a/net-im/pidgin/files/pidgin-2.13.0-python3_support.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-# HG changeset patch
-# User John Bailey <rekkanoryo@rekkanoryo.org>
-# Date 1527918187 14400
-# Sat Jun 02 01:43:07 2018 -0400
-# Branch upstream-fedora-patches
-# Node ID ab3a54cf9afbd2a1cb6736c7ee424d8fc82e7b14
-# Parent de18cefddad5ffe593a192f3a20f6f91165ab516
-Modified Jan Synacek's purple-remote python3 compatibility patch to make it
-compatible with both python2 and python3.
-
-diff --git a/COPYRIGHT b/COPYRIGHT
---- a/COPYRIGHT
-+++ b/COPYRIGHT
-@@ -544,6 +544,7 @@
- Sun Microsystems
- Marcus Sundberg
- Mårten Svantesson (fursten)
-+Jan Synacek <jsynacek@redhat.com>
- Amir Szekely (kichik)
- Gábor Szuromi (kukkerman)
- Jakub Szypulka
-diff --git a/libpurple/purple-remote b/libpurple/purple-remote
---- a/libpurple/purple-remote
-+++ b/libpurple/purple-remote
-@@ -14,7 +14,11 @@
- import xml.dom.minidom
-
- sys.stdin = codecs.getwriter('utf-8')(sys.stdin);
--sys.stdout = codecs.getwriter('utf-8')(sys.stdout);
-+
-+if(sys.version_info > (3,0)):
-+ sys.stdout = codecs.getwriter('utf-8')(sys.stdout.detach());
-+else:
-+ sys.stdout = codecs.getwriter('utf-8')(sys.stdout);
-
- xml.dom.minidom.Element.all = xml.dom.minidom.Element.getElementsByTagName
-