summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-18 11:32:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-18 11:39:08 +0200
commita3cc7df7f919becfaf08ce68a93712fbffbd0b6d (patch)
treedfaa97faa47d14fabd9cd674bb34c4e84c113956 /net-im/poezio/poezio-9999.ebuild
parentmedia-video/celluloid: amd64 stable wrt bug #717892 (diff)
downloadgentoo-a3cc7df7f919becfaf08ce68a93712fbffbd0b6d.tar.gz
gentoo-a3cc7df7f919becfaf08ce68a93712fbffbd0b6d.tar.bz2
gentoo-a3cc7df7f919becfaf08ce68a93712fbffbd0b6d.zip
net-im/poezio: Fix running tests, use correct deps
Upstream uses pytest in tests, so we need to depend on it. Using pytest also avoids failures due to missing optional runtime deps that are not used in tests at all. Closes: https://bugs.gentoo.org/717884 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-im/poezio/poezio-9999.ebuild')
-rw-r--r--net-im/poezio/poezio-9999.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
index 14be76f1d818..2946371c46b8 100644
--- a/net-im/poezio/poezio-9999.ebuild
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -10,8 +10,6 @@ DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
HOMEPAGE="https://poez.io/"
LICENSE="ZLIB"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
@@ -27,12 +25,8 @@ RDEPEND="
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/slixmpp[${PYTHON_USEDEP}]
"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/potr
- dev-python/pyinotify
- )"
+
+distutils_enable_tests pytest
DOC_CONTENTS="
Install these optional runtime dependencies for additional features.
@@ -55,7 +49,3 @@ src_install() {
pkg_postinst() {
readme.gentoo_print_elog
}
-
-python_test() {
- esetup.py test
-}