summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-10-14 19:01:38 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-10-14 19:38:50 +0100
commite42984246dcfff318b17b9a521a331ebfb431d5f (patch)
tree47ef8aa4885595330da6e942a67191c3a23990d1 /net-im/profanity/profanity-0.7.1.ebuild
parentnet-libs/libsignal-protocol-c: add new package (diff)
downloadgentoo-e42984246dcfff318b17b9a521a331ebfb431d5f.tar.gz
gentoo-e42984246dcfff318b17b9a521a331ebfb431d5f.tar.bz2
gentoo-e42984246dcfff318b17b9a521a331ebfb431d5f.zip
net-im/profanity: add 0.7.1 ebuild
Copied from 0.6.0 ebuild with SRC_URI updated with latest URL advertised by upstream. Old URL doesn't work anymore. Bug: https://bugs.gentoo.org/697644 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-im/profanity/profanity-0.7.1.ebuild')
-rw-r--r--net-im/profanity/profanity-0.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-im/profanity/profanity-0.7.1.ebuild b/net-im/profanity/profanity-0.7.1.ebuild
new file mode 100644
index 000000000000..1e3e1435fe18
--- /dev/null
+++ b/net-im/profanity/profanity-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://profanity-im.github.io/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify otr gpg xscreensaver"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode]
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}