summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-13 20:36:56 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-13 20:38:57 +0100
commit7a9cccd620f7c0aa0a0f501df1f84fd0c2094af4 (patch)
tree404e2b4e11e78e02447767865d4a5d07c88a2662 /net-im/prosody
parentapp-misc/fhem: migrate to tmpfiles eclass (diff)
downloadgentoo-7a9cccd620f7c0aa0a0f501df1f84fd0c2094af4.tar.gz
gentoo-7a9cccd620f7c0aa0a0f501df1f84fd0c2094af4.tar.bz2
gentoo-7a9cccd620f7c0aa0a0f501df1f84fd0c2094af4.zip
net-im/prosody: migrate to tmpfiles eclass
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/prosody-0.11.5-r1.ebuild50
1 files changed, 28 insertions, 22 deletions
diff --git a/net-im/prosody/prosody-0.11.5-r1.ebuild b/net-im/prosody/prosody-0.11.5-r1.ebuild
index 6ffc3bd7b489..2e89c9c96e9e 100644
--- a/net-im/prosody/prosody-0.11.5-r1.ebuild
+++ b/net-im/prosody/prosody-0.11.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit multilib systemd toolchain-funcs
+inherit multilib systemd tmpfiles toolchain-funcs
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua"
HOMEPAGE="https://prosody.im/"
@@ -15,28 +15,34 @@ KEYWORDS="amd64 arm x86"
IUSE="ipv6 jit libevent libressl mysql postgres sqlite ssl test zlib"
RESTRICT="!test? ( test )"
-BASE_DEPEND="net-im/jabber-base
- dev-lua/LuaBitOp
- !jit? ( >=dev-lang/lua-5.1:0 )
- jit? ( dev-lang/luajit:2 )
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl:= )
- >=net-dns/libidn-1.1:="
+BASE_DEPEND="
+ net-im/jabber-base
+ dev-lua/LuaBitOp
+ !jit? ( >=dev-lang/lua-5.1:0 )
+ jit? ( dev-lang/luajit:2 )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl:= )
+ >=net-dns/libidn-1.1:=
+"
-DEPEND="${BASE_DEPEND}
- test? ( dev-lua/busted )"
+DEPEND="
+ ${BASE_DEPEND}
+ test? ( dev-lua/busted )
+"
-RDEPEND="${BASE_DEPEND}
- ~dev-lua/luaexpat-1.3.0
- dev-lua/luafilesystem
- !ipv6? ( dev-lua/luasocket )
- ipv6? ( >=dev-lua/luasocket-3 )
- libevent? ( >=dev-lua/luaevent-0.4.3 )
- mysql? ( dev-lua/luadbi[mysql] )
- postgres? ( dev-lua/luadbi[postgres] )
- sqlite? ( dev-lua/luadbi[sqlite] )
- ssl? ( dev-lua/luasec )
- zlib? ( dev-lua/lua-zlib )"
+RDEPEND="
+ ${BASE_DEPEND}
+ ~dev-lua/luaexpat-1.3.0
+ dev-lua/luafilesystem
+ !ipv6? ( dev-lua/luasocket )
+ ipv6? ( >=dev-lua/luasocket-3 )
+ libevent? ( >=dev-lua/luaevent-0.4.3 )
+ mysql? ( dev-lua/luadbi[mysql] )
+ postgres? ( dev-lua/luadbi[postgres] )
+ sqlite? ( dev-lua/luadbi[sqlite] )
+ ssl? ( dev-lua/luasec )
+ zlib? ( dev-lua/lua-zlib )
+"
PATCHES=( "${FILESDIR}/${PN}-0.11.2-r1-gentoo.patch" )
@@ -66,7 +72,7 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
- systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
+ newtmpfiles "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r2 ${PN}
keepdir "${JABBER_SPOOL}"
}