summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-03 20:26:15 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-03 20:34:52 +0200
commitb4ccfc45a8a2afe0ba1cb941091474724e16774b (patch)
tree5d3c24c0f3a6ec874910a94a0b454ac8b4ca7679 /net-im/prosody
parentpackage.mask: Last rite dev-dotnet/mono-addins and revdep (diff)
downloadgentoo-b4ccfc45a8a2afe0ba1cb941091474724e16774b.tar.gz
gentoo-b4ccfc45a8a2afe0ba1cb941091474724e16774b.tar.bz2
gentoo-b4ccfc45a8a2afe0ba1cb941091474724e16774b.zip
net-im/prosody: add notice back
Also remove duplicate initd install. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/prosody-0.11.7.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-im/prosody/prosody-0.11.7.ebuild b/net-im/prosody/prosody-0.11.7.ebuild
index 82f956657646..041e5c27e526 100644
--- a/net-im/prosody/prosody-0.11.7.ebuild
+++ b/net-im/prosody/prosody-0.11.7.ebuild
@@ -46,7 +46,7 @@ RDEPEND="
PATCHES=( "${FILESDIR}/${PN}-0.11.2-r1-gentoo.patch" )
src_configure() {
- local myconfargs=(
+ local myeconfargs=(
--c-compiler="$(tc-getCC)"
--datadir="${EPREFIX}/var/spool/jabber"
--libdir="${EPREFIX}/usr/$(get_libdir)"
@@ -59,7 +59,9 @@ src_configure() {
--with-lua-lib="${EPREFIX}/usr/$(get_libdir)/lua"
)
- ./configure ${myconfargs[@]} --cflags="${CFLAGS} -Wall -fPIC" --ldflags="${LDFLAGS} -shared" || die
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure ${myeconfargs[@]} --cflags="${CFLAGS} -Wall -fPIC" --ldflags="${LDFLAGS} -shared" || die
rm makefile || die
mv GNUmakefile Makefile || die
@@ -74,6 +76,4 @@ src_install() {
systemd_dounit "${FILESDIR}"/prosody.service
systemd_newtmpfilesd "${FILESDIR}"/prosody.tmpfilesd prosody.conf
-
- newinitd "${FILESDIR}"/prosody.initd-r3 prosody
}