summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2018-07-11 05:11:50 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-12 18:58:12 +0200
commit2b3880f361217486bc16187109f5bd6c71562909 (patch)
tree2e8b9fc5a2b34dfa92d208cbeab2e4b7dee4cfdc /net-im/qtox/qtox-1.16.3.ebuild
parentnet-libs/tox: version bump to 0.2.5 (diff)
downloadgentoo-2b3880f361217486bc16187109f5bd6c71562909.tar.gz
gentoo-2b3880f361217486bc16187109f5bd6c71562909.tar.bz2
gentoo-2b3880f361217486bc16187109f5bd6c71562909.zip
net-im/qtox: version bump to 1.16.3
Bug: https://bugs.gentoo.org/635636 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-im/qtox/qtox-1.16.3.ebuild')
-rw-r--r--net-im/qtox/qtox-1.16.3.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-im/qtox/qtox-1.16.3.ebuild b/net-im/qtox/qtox-1.16.3.ebuild
new file mode 100644
index 000000000000..4bd474cc1f42
--- /dev/null
+++ b/net-im/qtox/qtox-1.16.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils xdg-utils
+
+MY_P="qTox-${PV}"
+DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
+HOMEPAGE="https://github.com/qTox/qTox"
+SRC_URI="https://github.com/qTox/qTox/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="notification test X"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ dev-db/sqlcipher
+ dev-libs/libsodium:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[gif,jpeg,png,xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-gfx/qrencode:=
+ media-libs/openal
+ >=media-video/ffmpeg-2.6.3:=[webp,v4l]
+ net-libs/tox:0/0.2[av]
+ notification? ( x11-libs/gtk+:2 )
+ X? ( x11-libs/libX11
+ x11-libs/libXScrnSaver )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ test? ( dev-qt/qttest:5 )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # bug 628574
+ if ! use test; then
+ sed -i CMakeLists.txt -e "/include(Testing)/d" || die
+ sed -i cmake/Dependencies.cmake -e "/find_package(Qt5Test/d" || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATUSNOTIFIER=$(usex notification)
+ -DENABLE_GTK_SYSTRAY=$(usex notification)
+ -DPLATFORM_EXTENSIONS=$(usex X)
+ -DUSE_FILTERAUDIO=OFF
+ -DGIT_DESCRIBE="${PV}"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}