summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2017-08-19 01:44:11 +0100
committerMichał Górny <mgorny@gentoo.org>2017-08-19 09:31:19 +0200
commit55768dacc7692722c4ca4fed90272b06f734eba8 (patch)
treefb96260ff11f35a2b72c79d3c1a139b4742d5a3b /net-im/qtox/qtox-9999.ebuild
parentdev-ruby/recog: install required xml files, fixing bug 628214 (diff)
downloadgentoo-55768dacc7692722c4ca4fed90272b06f734eba8.tar.gz
gentoo-55768dacc7692722c4ca4fed90272b06f734eba8.tar.bz2
gentoo-55768dacc7692722c4ca4fed90272b06f734eba8.zip
net-im/qtox: add updating icon cache and .desktop database
Also removed no longer needed toolchain-funcs from inherits. Closes: https://github.com/gentoo/gentoo/pull/5473 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-im/qtox/qtox-9999.ebuild')
-rw-r--r--net-im/qtox/qtox-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index cd4bd86f7e95..dd9f1a5c5026 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils eutils git-r3
+inherit cmake-utils eutils git-r3 gnome2-utils xdg-utils
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
HOMEPAGE="https://github.com/qTox/qTox"
@@ -53,3 +53,13 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}