summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/silc-server/silc-server-1.1.18.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/silc-server/silc-server-1.1.18.ebuild')
-rw-r--r--net-im/silc-server/silc-server-1.1.18.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-im/silc-server/silc-server-1.1.18.ebuild b/net-im/silc-server/silc-server-1.1.18.ebuild
new file mode 100644
index 000000000000..23fad3c2c4dd
--- /dev/null
+++ b/net-im/silc-server/silc-server-1.1.18.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic user
+
+DESCRIPTION="Server for Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/server/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gmp ipv6 debug"
+
+RDEPEND="!<=net-im/silc-toolkit-0.9.12-r1
+ !<=net-im/silc-client-1.0.1
+ gmp? ( dev-libs/gmp )"
+
+pkg_setup() {
+ enewuser silcd
+}
+
+src_configure() {
+ econf \
+ --datadir=/usr/share/${PN} \
+ --datarootdir=/usr/share/${PN} \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/silc \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-optimizations \
+ --with-logsdir=/var/log/${PN} \
+ --with-silcd-pid-file=/var/run/silcd.pid \
+ $(use_with gmp) \
+ $(use_enable ipv6) \
+ $(use_enable debug)
+}
+
+#src_compile() {
+# emake -j1
+#}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/silc
+ doins doc/silcalgs.conf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*.conf
+
+ fperms 600 /etc/silc
+ keepdir /var/log/${PN}
+
+ rm -rf \
+ "${D}"/usr/libsilc* \
+ "${D}"/usr/include \
+ "${D}"/etc/silc/silcd.{pub,prv}
+
+ newinitd "${FILESDIR}/silcd.initd-r1" silcd
+ doman doc/silcd.8 doc/silcd.conf.5
+
+ sed -i \
+ -e 's:10.2.1.6:0.0.0.0:' \
+ -e 's:User = "nobody";:User = "silcd";:' \
+ -e 's:/var/run:/run:' \
+ -e 's:lassi.kuo.fi.ssh.com:localhost:' \
+ doc/example_silcd.conf \
+ || die
+ dodoc doc/example_silcd.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${ROOT}"/etc/silc/silcd.prv ] ; then
+ einfo "Creating key pair in /etc/silc"
+ silcd -C "${ROOT}"/etc/silc
+ chmod 600 "${ROOT}"/etc/silc/silcd.{prv,pub}
+ fi
+}