summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-02 16:17:19 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-02 17:21:47 -0500
commit57dff2c099318bd33ed1b18f325400a317a90874 (patch)
tree128a596fbfd0f33bf9b755b9e50d1a87e25d9109 /net-im/simpserver-bin
parentnet-im/silc-server: remove old ebuild (diff)
downloadgentoo-57dff2c099318bd33ed1b18f325400a317a90874.tar.gz
gentoo-57dff2c099318bd33ed1b18f325400a317a90874.tar.bz2
gentoo-57dff2c099318bd33ed1b18f325400a317a90874.zip
net-im/simpserver-bin: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-im/simpserver-bin')
-rw-r--r--net-im/simpserver-bin/files/simpserver.rc4
-rw-r--r--net-im/simpserver-bin/simpserver-bin-2.1.0-r2.ebuild40
2 files changed, 42 insertions, 2 deletions
diff --git a/net-im/simpserver-bin/files/simpserver.rc b/net-im/simpserver-bin/files/simpserver.rc
index 4a48f5833ed2..16528fe0237c 100644
--- a/net-im/simpserver-bin/files/simpserver.rc
+++ b/net-im/simpserver-bin/files/simpserver.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-im/simpserver-bin/simpserver-bin-2.1.0-r2.ebuild b/net-im/simpserver-bin/simpserver-bin-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..7ee8c6349faf
--- /dev/null
+++ b/net-im/simpserver-bin/simpserver-bin-2.1.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN=${PN/-bin/}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SimpServer for Unix: IM instant security transparent proxy"
+SRC_URI="http://download.secway.com/public/products/simpserver/${MY_P}-linux-x86.tgz"
+HOMEPAGE="http://www.secway.com/"
+LICENSE="simpserver-test"
+
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+SLOT="0"
+S=${WORKDIR}/simp
+
+RESTRICT="strip"
+
+src_compile() {
+ einfo "Binary distribution. No compilation required."
+}
+
+src_install () {
+ dodoc README VERSION doc/CONFIG doc/TODO
+
+ exeinto /opt/bin
+ doexe bin/${MY_PN}
+
+ insinto /etc
+ doins etc/simp.conf
+
+ newinitd "${FILESDIR}/${MY_PN}".rc ${MY_PN}
+}
+
+pkg_postinst() {
+ elog "Please edit the configuration file: /etc/simp.conf."
+}