summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-03-24 14:28:35 +0800
committerYixun Lan <dlan@gentoo.org>2021-03-24 14:33:17 +0800
commitadba580be72f0b3613d7237954532f9f6b6d58f6 (patch)
treec675d184d820a53b21fd6a22f20cc1a316fdb640 /net-im/slack
parentmedia-radio/wsjtx: Add subslot dependencies (diff)
downloadgentoo-adba580be72f0b3613d7237954532f9f6b6d58f6.tar.gz
gentoo-adba580be72f0b3613d7237954532f9f6b6d58f6.tar.bz2
gentoo-adba580be72f0b3613d7237954532f9f6b6d58f6.zip
net-im/slack: restore 4.12.2 for now
Bug: https://bugs.gentoo.org/772137 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-im/slack')
-rw-r--r--net-im/slack/Manifest1
-rw-r--r--net-im/slack/slack-4.12.2.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-im/slack/Manifest b/net-im/slack/Manifest
index 50a81d66fd71..bf33169a8377 100644
--- a/net-im/slack/Manifest
+++ b/net-im/slack/Manifest
@@ -1,2 +1,3 @@
+DIST slack-desktop-4.12.2-amd64.deb 57734610 BLAKE2B 249565bcb3f5fd9467d2b48e683978f406be6e3fd77f56c8e6ee328a3745800e53504f9bd618ea1764ffe429256ca5610b53996f82442e399d47f46ee5991b78 SHA512 7c0ef6e007f67c9a95c43e6544536af35d9bb55008524dade5b707aa4473db8e0837547bb91f8398728fcdc9e4ec732655cd390b49f1b5f820dc3f0b73ef9f71
DIST slack-desktop-4.13.0-amd64.deb 57716072 BLAKE2B b8f1a793239b1e101bb6eb738a8a75883bf67468886f954226552074b769355b5444bbe9273eed48575b5f245fb47bdc78e264e7329ef052305afbec88f496f4 SHA512 d324637cb96a73f6d93fb36cfee52625d9c3571115ca6a8f0e7891417dd5fa88172dcc001e1a4fc9396392fe4885c5b14d9618d82c6a97b7c688ae14f5cbe8d9
DIST slack-desktop-4.14.0-amd64.deb 59988434 BLAKE2B 38bc579bb493c9e2c82713d8578167c268c2c44a028f6ebeb7c95a98832f265393df988f01ea5149fd3fd7bbdd24129fcb28b68cd70d0c3444cdb566e7991947 SHA512 babfcd416b3551a1a6390899fdd89ef20cd3d4731f32b3947b99ab02a566a92a5092f8e78a09f43a1363a9de8699be40d263c47d3a6b123a6cc5e7bbcac16352
diff --git a/net-im/slack/slack-4.12.2.ebuild b/net-im/slack/slack-4.12.2.ebuild
new file mode 100644
index 000000000000..2a34f4ae27fa
--- /dev/null
+++ b/net-im/slack/slack-4.12.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop multilib-build optfeature pax-utils unpacker xdg
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="https://www.slack.com"
+SRC_URI="https://downloads.slack-edge.com/linux_releases/${PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="appindicator suid"
+RESTRICT="bindist mirror"
+
+RDEPEND="app-accessibility/at-spi2-atk:2[${MULTILIB_USEDEP}]
+ app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/mesa:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libdrm:0[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]
+ appindicator? ( dev-libs/libappindicator:3[${MULTILIB_USEDEP}] )"
+
+QA_PREBUILT="/opt/slack/chrome-sandbox
+ /opt/slack/libEGL.so
+ /opt/slack/libffmpeg.so
+ /opt/slack/libGLESv2.so
+ /opt/slack/libvk_swiftshader.so
+ /opt/slack/libvulkan.so
+ /opt/slack/resources/app.asar.unpacked/node_modules/*/*/build/Release/*.node
+ /opt/slack/resources/app.asar.unpacked/node_modules/*/build/Release/*.node
+ /opt/slack/slack
+ /opt/slack/swiftshader/libEGL.so
+ /opt/slack/swiftshader/libGLESv2.so"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # remove hardcoded path, logging noise (wrt 694058, 711494)
+ sed -i -e '/Icon/s|/usr/share/pixmaps/slack.png|slack|' \
+ -e '/Exec/s|slack|slack -s|' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed in Icon for slack.desktop"
+
+ if use appindicator ; then
+ sed -i '/Exec/s|=|=env XDG_CURRENT_DESKTOP=Unity |' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for slack.desktop"
+ fi
+
+ rm usr/lib/slack/LICENSE{,S-linux.json} \
+ || die "rm licenses failed"
+}
+
+src_install() {
+ doicon usr/share/pixmaps/slack.png
+ doicon -s 512 usr/share/pixmaps/slack.png
+ domenu usr/share/applications/slack.desktop
+
+ insinto /opt # wrt 720134
+ cp -a usr/lib/slack "${ED}"/opt || die "cp failed"
+
+ use suid && fperms u+s /opt/slack/chrome-sandbox # wrt 713094
+ dosym ../../opt/slack/slack usr/bin/slack
+
+ pax-mark -m "${ED}"/opt/slack/slack
+}
+
+pkg_postinst() {
+ optfeature "storing passwords via gnome-keyring" app-crypt/libsecret
+
+ xdg_pkg_postinst
+}