summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2021-08-12 11:09:33 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-08-12 10:39:12 -0700
commit3bd39ad0be7cafc8fd2ea2f49762c2bd34e8df38 (patch)
tree0f74af151ebbc3c67f3032fed7065c6a5960e586 /net-im/telegram-desktop
parentnet-im/telegram-desktop: Rebuild whenever tg_owt flags change (diff)
downloadgentoo-3bd39ad0be7cafc8fd2ea2f49762c2bd34e8df38.tar.gz
gentoo-3bd39ad0be7cafc8fd2ea2f49762c2bd34e8df38.tar.bz2
gentoo-3bd39ad0be7cafc8fd2ea2f49762c2bd34e8df38.zip
net-im/telegram-desktop: Bump to 2.9.3
Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Manifest2
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.9.0-fix-disable-wayland-integration.patch11
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch31
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.9.3.ebuild (renamed from net-im/telegram-desktop/telegram-desktop-2.9.0-r1.ebuild)8
4 files changed, 36 insertions, 16 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 060040b4c96e..19aaf880f2c6 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,2 +1,2 @@
DIST tdesktop-2.8.11-full.tar.gz 37105468 BLAKE2B 1ec5a0003bd1b948b45213509fa0649dfde5ec8e3dff097bf45aa0951c7963930788b0bee853f286d04b008b78704c464b6614b8391350767affebc2623b25af SHA512 a553313b04fbb562745be2381a84117657172952e46e280980a73c9fcfe2a7cf29c0e012e4b1259816d1e6652418e7a1ddfc4e394544fcc3aeb33704cbe80860
-DIST tdesktop-2.9.0-full.tar.gz 37327425 BLAKE2B f47abfd41e71dbf950e6357417fd2725b145286861f6dfc8edc4101b6b232c43ea7a9987d028e57979588bf44919fef2e89b00adae7a9843e52f8f2566013dd8 SHA512 e9be60cdaeffa4efa95ea1e5d8fe50308bff5612b546fa92c02f824f479b42e098fb8fbe713e652578ee2308e3faadaf82e4c101dee0e58b6f3c70d8dcb0bd8e
+DIST tdesktop-2.9.3-full.tar.gz 37335782 BLAKE2B 197583ba6568c455218c51f590c1ba1a3f10c390caa4fd03657098f499ce113a4f5f57ca9dd53bc4baba31992d4229768ed35e68ad6b0685010bc335817edcac SHA512 810cfac5d7e6ce9413b1b2406927e89c1383ea5b725233a68b2cb29dd374b4c3386c22186640afde4492c844516c88889a5db8e5b167a09d6d6c1270ac965ac4
diff --git a/net-im/telegram-desktop/files/tdesktop-2.9.0-fix-disable-wayland-integration.patch b/net-im/telegram-desktop/files/tdesktop-2.9.0-fix-disable-wayland-integration.patch
deleted file mode 100644
index c76bcc06dfdb..000000000000
--- a/net-im/telegram-desktop/files/tdesktop-2.9.0-fix-disable-wayland-integration.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- tdesktop-2.9.0-full.orig/Telegram/lib_ui/ui/platform/linux/ui_linux_wayland_integration_dummy.cpp
-+++ tdesktop-2.9.0-full/Telegram/lib_ui/ui/platform/linux/ui_linux_wayland_integration_dummy.cpp
-@@ -18,6 +18,8 @@
- WaylandIntegration::WaylandIntegration() {
- }
-
-+WaylandIntegration::~WaylandIntegration() = default;
-+
- WaylandIntegration *WaylandIntegration::Instance() {
- if (!::Platform::IsWayland()) return nullptr;
- static WaylandIntegration instance;
diff --git a/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch
new file mode 100644
index 000000000000..f90270fccee3
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch
@@ -0,0 +1,31 @@
+Only link jemalloc for the Telegram binary
+
+Some combination of factors is making the different codegen tools hang when
+jemalloc is linked for those, and they're ran under portage's sandbox. Since
+this is only used during build-time, and jemalloc is merely necessary to
+improve runtime memory use, it's unnecessary to use it for anything else.
+
+--- tdesktop-2.9.3-full.orig/Telegram/CMakeLists.txt
++++ tdesktop-2.9.3-full/Telegram/CMakeLists.txt
+@@ -1264,6 +1264,7 @@
+ PRIVATE
+ desktop-app::external_glibmm
+ desktop-app::external_glib
++ desktop-app::external_jemalloc
+ )
+
+ if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
+--- tdesktop-2.9.3-full.orig/cmake/options_linux.cmake
++++ tdesktop-2.9.3-full/cmake/options_linux.cmake
+@@ -45,11 +45,6 @@
+ endif()
+ endif()
+
+-target_link_libraries(common_options
+-INTERFACE
+- desktop-app::external_jemalloc
+-)
+-
+ if (DESKTOP_APP_USE_ALLOCATION_TRACER)
+ target_link_options(common_options
+ INTERFACE
diff --git a/net-im/telegram-desktop/telegram-desktop-2.9.0-r1.ebuild b/net-im/telegram-desktop/telegram-desktop-2.9.3.ebuild
index 7ed38b44c9db..38257e0072ae 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.9.0-r1.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.9.3.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${
LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
-IUSE="+dbus enchant +gtk +hunspell +spell wayland webkit +X"
+IUSE="+dbus enchant +gtk +hunspell screencast +spell wayland webkit +X"
REQUIRED_USE="
spell? (
^^ ( enchant hunspell )
@@ -24,6 +24,7 @@ REQUIRED_USE="
webkit? ( gtk )
gtk? ( dbus )
"
+# Future: webkit doesn't depend on gtk anymore (version: >2.9.3)
RDEPEND="
!net-im/telegram-desktop-bin
@@ -44,7 +45,7 @@ RDEPEND="
media-libs/openal
media-libs/opus:=
media-libs/rnnoise
- ~media-libs/tg_owt-0_pre20210626
+ ~media-libs/tg_owt-0_pre20210626[screencast=,X=]
media-video/ffmpeg:=[opus]
sys-libs/zlib:=[minizip]
dbus? (
@@ -71,8 +72,7 @@ BDEPEND="
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}/tdesktop-2.8.10-jemalloc-only-telegram.patch"
- "${FILESDIR}/tdesktop-2.9.0-fix-disable-wayland-integration.patch"
+ "${FILESDIR}/tdesktop-2.9.3-jemalloc-only-telegram.patch"
)
pkg_pretend() {