summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-11 09:04:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-11 17:59:07 +0200
commitf88d0c50f937634cee60f2232a3e89ae0d06f8b1 (patch)
tree9f7bd2f2b08c30f6b537cff44c8ed1f02df3e17d /net-im/tokodon/tokodon-23.04.1.ebuild
parentnet-im/neochat: 23.04.1 version bump (diff)
downloadgentoo-f88d0c50f937634cee60f2232a3e89ae0d06f8b1.tar.gz
gentoo-f88d0c50f937634cee60f2232a3e89ae0d06f8b1.tar.bz2
gentoo-f88d0c50f937634cee60f2232a3e89ae0d06f8b1.zip
net-im/tokodon: 23.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/tokodon/tokodon-23.04.1.ebuild')
-rw-r--r--net-im/tokodon/tokodon-23.04.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-im/tokodon/tokodon-23.04.1.ebuild b/net-im/tokodon/tokodon-23.04.1.ebuild
new file mode 100644
index 000000000000..e11e41db902a
--- /dev/null
+++ b/net-im/tokodon/tokodon-23.04.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.104.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Mastodon client for Plasma and Plasma Mobile"
+HOMEPAGE="https://apps.kde.org/tokodon/"
+
+LICENSE="CC-BY-SA-4.0 GPL-2+ GPL-3+ || ( LGPL-2.1+ LGPL-3+ ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/kirigami-addons-0.7.2:5
+ dev-libs/qtkeychain:=[qt5(+)]
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwebsockets-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5[qml]
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5[qml]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-23.04.0-tokodon-not-neochat.patch" ) # git master
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ ecm_src_test
+}