summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 14:50:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-16 20:29:14 +0100
commitfcd6244ac13c947b1358366e4a1d9c48f9249714 (patch)
treef87fc120a4e88595ac6c76119b9d639a41b00417 /net-im/transwhat
parentnet-im/yowsup: drop old version (diff)
downloadgentoo-fcd6244ac13c947b1358366e4a1d9c48f9249714.tar.gz
gentoo-fcd6244ac13c947b1358366e4a1d9c48f9249714.tar.bz2
gentoo-fcd6244ac13c947b1358366e4a1d9c48f9249714.zip
net-im/transwhat: bump to EAPI=7
Also updated metadata.xml and license. Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10265 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/transwhat')
-rw-r--r--net-im/transwhat/metadata.xml4
-rw-r--r--net-im/transwhat/transwhat-0.2.2-r1.ebuild37
2 files changed, 41 insertions, 0 deletions
diff --git a/net-im/transwhat/metadata.xml b/net-im/transwhat/metadata.xml
index 91277090fe3b..3be736289c91 100644
--- a/net-im/transwhat/metadata.xml
+++ b/net-im/transwhat/metadata.xml
@@ -12,4 +12,8 @@
<longdescription>
transWhat is a WhatsApp XMPP Gateway based on Spectrum 2 and Yowsup 2.
</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/stv0g/transwhat/issues</bugs-to>
+ <remote-id type="github">stv0g/transwhat</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-im/transwhat/transwhat-0.2.2-r1.ebuild b/net-im/transwhat/transwhat-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..3023b97715b4
--- /dev/null
+++ b/net-im/transwhat/transwhat-0.2.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WhatsApp XMPP Gateway based on Spectrum 2 and Yowsup 2"
+HOMEPAGE="https://github.com/stv0g/transwhat"
+SRC_URI="https://github.com/stv0g/transwhat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/e4u[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ net-im/yowsup[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( "INSTALL.rst" "README.rst" "USAGE.rst" )
+
+src_prepare() {
+ default
+
+ # Fixes for net-im/spectrum2
+ mv config.py Spectrum2/config.py || die
+ sed -i -e 's/config import SpectrumConfig/Spectrum2.&/' transWhat/transwhat.py || die
+}