summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-11 21:12:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-11 21:13:28 +0100
commit68d2c7eafe4a95a579dcd4835a029b4036099feb (patch)
treecfe4689ab03b9d858764ca5f17480731f6e1bc61 /net-im/yowsup
parentsci-mathematics/z3: Stabilize 4.8.14 arm, #833068 (diff)
downloadgentoo-68d2c7eafe4a95a579dcd4835a029b4036099feb.tar.gz
gentoo-68d2c7eafe4a95a579dcd4835a029b4036099feb.tar.bz2
gentoo-68d2c7eafe4a95a579dcd4835a029b4036099feb.zip
net-im/yowsup: add 3.3.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/yowsup')
-rw-r--r--net-im/yowsup/Manifest1
-rw-r--r--net-im/yowsup/yowsup-3.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-im/yowsup/Manifest b/net-im/yowsup/Manifest
index 36bedc4cf104..a15f135eaf4d 100644
--- a/net-im/yowsup/Manifest
+++ b/net-im/yowsup/Manifest
@@ -1 +1,2 @@
DIST yowsup-3.2.3_p20190905.tar.gz 150149 BLAKE2B 149c49df1a3b4df9163abcb1625b7e15e41d81f6a1a649c08d8cca88cce6cf10488778301fc96af3b2fe9e668e855023e56da6e6e8b3b9038994273f19404b78 SHA512 4b59a30bf73797750b92aecf45bf2e551fcbb249688efac631400bf532e21b739e9a6628ed01da4d520ed9296657ae8c5463c3560b165c5d696fd18f1e700be7
+DIST yowsup-3.3.0.tar.gz 155950 BLAKE2B 7ade7f7e05aff14d5154d35d5c2a1841ee66893059bd995facb8297d7e6f1dde4468105dc3f03b5462efbf92cbd079c457440bb1580235bbbcfaddeab2244b56 SHA512 304409f02aa3720b0f70a83fe4dbe288fa1c5659642878d7bd1354359524a66c39b9f5baa9899224497f61f974d9b64ba67e07d866fda2589413070bb9ef1aad
diff --git a/net-im/yowsup/yowsup-3.3.0.ebuild b/net-im/yowsup/yowsup-3.3.0.ebuild
new file mode 100644
index 000000000000..660ae5def7a9
--- /dev/null
+++ b/net-im/yowsup/yowsup-3.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# This package contains no-op tests, so they actually cannot be run
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/consonance[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.2.3_p20190905-fix-install-path.patch" )
+
+src_prepare() {
+ default
+
+ # After talking to upstream, version restriction can be lifted
+ # and also 'argparse' needs to be removed.
+ sed -e 's/==0.1.5//' -e 's/==0.2.2//' -e 's/==1.10//' -e 's/>=3.6.0//' -e 's/argparse//' -i setup.py || die
+}