summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 13:05:51 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 13:06:10 -0400
commit159f337e908f4b7c9dff13ebd92df7adcc3e27b5 (patch)
treef27d1579c2e084427fb546402b091f370e3392ce /net-im
parentdev-python/atomicwrites: version bump 0.1.9 (diff)
downloadgentoo-159f337e908f4b7c9dff13ebd92df7adcc3e27b5.tar.gz
gentoo-159f337e908f4b7c9dff13ebd92df7adcc3e27b5.tar.bz2
gentoo-159f337e908f4b7c9dff13ebd92df7adcc3e27b5.zip
net-im/minbif: fix build with newer imlib.
Newer versions of imlib have renamed ImlibLoadError to Imlib_Load_Error. This commit adds a minimal patch to fix the build. It's bad mojo to modify a stable ebuild, but there are mitigating factors here. First, the stable package simply will not build without the patch, so it's not much good to anyone. Second, this package is maintainer-needed, and a new revision would therefore never get stabilized to truly fix the bug for stable users. So, I've applied the patch to the one existing stable ebuild. Gentoo-Bug: 559412 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-im')
-rw-r--r--net-im/minbif/files/minbif-1.0.5-rename-imlib-load-error.patch13
-rw-r--r--net-im/minbif/minbif-1.0.5-r2.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/net-im/minbif/files/minbif-1.0.5-rename-imlib-load-error.patch b/net-im/minbif/files/minbif-1.0.5-rename-imlib-load-error.patch
new file mode 100644
index 000000000000..e9fa875d247c
--- /dev/null
+++ b/net-im/minbif/files/minbif-1.0.5-rename-imlib-load-error.patch
@@ -0,0 +1,13 @@
+diff --git a/src/im/account.cpp b/src/im/account.cpp
+index f155334..f040fcd 100644
+--- a/src/im/account.cpp
++++ b/src/im/account.cpp
+@@ -272,7 +272,7 @@ void Account::setBuddyIcon(string filename)
+ else
+ {
+ char** prpl_formats = g_strsplit(prplinfo->icon_spec.format,",",0);
+- ImlibLoadError err = IMLIB_LOAD_ERROR_UNKNOWN;
++ Imlib_Load_Error err = IMLIB_LOAD_ERROR_UNKNOWN;
+
+ close(temp_fd);
+ /* Try to encode in a supported format. */
diff --git a/net-im/minbif/minbif-1.0.5-r2.ebuild b/net-im/minbif/minbif-1.0.5-r2.ebuild
index 0262b1a52067..b50395ca5bd2 100644
--- a/net-im/minbif/minbif-1.0.5-r2.ebuild
+++ b/net-im/minbif/minbif-1.0.5-r2.ebuild
@@ -37,6 +37,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/${PN}-1.0.5-glib-single-includes.patch"
epatch "${FILESDIR}/${PN}-1.0.5-gcc47.patch"
+ epatch "${FILESDIR}/${PN}-1.0.5-rename-imlib-load-error.patch"
sed -i "s/-Werror//g" CMakeLists.txt || die "sed failed"