summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-03 21:28:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-03 21:52:03 +0100
commit1c0b674fc9fc60d142e3119333ec21ed4cf718d8 (patch)
tree36a2cfeffe7efc556eae09c85ee41b2db88da514 /net-im
parentnet-misc/realtek-r8152: refresh depmod upon installation. (diff)
downloadgentoo-1c0b674fc9fc60d142e3119333ec21ed4cf718d8.tar.gz
gentoo-1c0b674fc9fc60d142e3119333ec21ed4cf718d8.tar.bz2
gentoo-1c0b674fc9fc60d142e3119333ec21ed4cf718d8.zip
et-im/libcommuni: bump to version 3.6.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libcommuni/Manifest1
-rw-r--r--net-im/libcommuni/libcommuni-3.6.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
index 48032e6f51cf..657c5e33d474 100644
--- a/net-im/libcommuni/Manifest
+++ b/net-im/libcommuni/Manifest
@@ -1 +1,2 @@
DIST libcommuni-3.5.0_p20200711.tar.gz 471839 BLAKE2B 37a02c473496a0fe9394a8b019678afa96b07b9272556fd538d42d9ec296b34ad4c76b3110ff96732bccbed59f2faeedf80bd7782e7a6e395252c6430cb88fa7 SHA512 578e2f70bdfa0e62eb3acac4e8deb2f6f0c1cd5f0a5e559dae79d2a808b27d3cf63ede146a65026e156d988097a5b7903793acadcd7e9ac567f65c59e6738ed3
+DIST libcommuni-3.6.0.tar.gz 472634 BLAKE2B 0d3d68e27f75cd59ebd61532261e2d3d2c0c2d61d6e08e5b4ed2b21bbf75572f4ce1763fbc4f66c8d5f7c8f9859240ddff5daceeb548d82e2efe936a265031b7 SHA512 cf872d0cdc281a452129a05f5a903eeec3661a4d0d56bdc61bdf95ea969c7b1bcb68534d3d8999fb85ef2b81f17c067b5cd3437351d4635efae3c714567518c0
diff --git a/net-im/libcommuni/libcommuni-3.6.0.ebuild b/net-im/libcommuni/libcommuni-3.6.0.ebuild
new file mode 100644
index 000000000000..2b9e4f1c6d9d
--- /dev/null
+++ b/net-im/libcommuni/libcommuni-3.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="https://communi.github.io/"
+SRC_URI="https://github.com/communi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qml test +uchardet"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ examples? ( || (
+ dev-qt/qtgui:5[X(-)]
+ dev-qt/qtgui:5[xcb(-)]
+ ) )
+ uchardet? ( app-i18n/uchardet )
+ !uchardet? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local myqmakeargs=( libcommuni.pro
+ # Disables compile run-time benchmarks, as they don't make any sense
+ -config no_benchmarks
+ # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+ -config no_rpath
+ # Compile libcommuni always in Release mode, as Debug seems to do nothing
+ -config release
+ # Don't silence all compile messages
+ -config verbose
+ -config $(usex examples '' 'no_')examples
+ -config $(usex qml '' 'no_')qml
+ -config $(usex test '' 'no_')tests
+ -config $(usex uchardet 'no_' '')icu
+ -config $(usex uchardet '' 'no_')uchardet )
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+ # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+ # The test will fail, when libcommuni is emerged with USE="uchardet" and
+ # libcommuni is already installed with USE="-uchardat", or the other way around.
+ find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+ local -x LD_LIBRARY_PATH="${S}/lib"
+
+ default
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ if use examples; then
+ local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
+ for example in ${examples[@]}; do
+ newbin examples/"${example}"/"${example}" libcommuni."${example}"
+ done
+ fi
+
+ einstalldocs
+}