summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-10 08:48:38 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-10 08:48:38 +0200
commit26ba8de0d09277648b1a319ba9eff553a1908078 (patch)
tree808d22ab697a4344ba5a000540c6f4c7774c0064 /net-im
parentwww-plugins/chrome-binary-plugins: automated update (95.0.4636.4) (diff)
downloadgentoo-26ba8de0d09277648b1a319ba9eff553a1908078.tar.gz
gentoo-26ba8de0d09277648b1a319ba9eff553a1908078.tar.bz2
gentoo-26ba8de0d09277648b1a319ba9eff553a1908078.zip
net-im/rocketchat-desktop-bin: add version 3.5.3
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 6bacb2b6c891..34fd6ceb933c 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.2.x86_64.rpm 58600396 BLAKE2B abc2896ede173b3c1df6f9877cf1e629c5618eec50c4974b2fe5602d054ae412b910d06c601a02dd3c27466e86e4076ca76372b2f2553d9677e2f2e8b9ab63eb SHA512 adb0dfd51f4e63f1dbc471ac32627537ccd10780b81cae05d07b94a5cbacb4694f1278c49e9399eefe695fef1b8f3e2e75a7114b3711b5487b5bada2e339f433
+DIST rocketchat-3.5.3.x86_64.rpm 58606036 BLAKE2B 22a13b9f5410e24c54b9426ee1d9c5d13affdee450d45c7a933e5f8bacb008de1e18c0af2ad31d89dad0c54e1212b93362fece21d724218275d38140180407ea SHA512 84ccdd4b99c257a1f4b0bdf4fb2b10b30f6b1acc5c6e1d92a03912f711cf56d9f423e7984431cfd74de9a805c181f4fe83c8893e7dff8fd50fa548ac4892b1fc
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.3.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.3.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}