summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-08-26 09:21:44 +0200
committerHanno <hanno@gentoo.org>2019-08-26 09:21:44 +0200
commit32f9d234b4406bf51e6faca93cc8bdea2762fb97 (patch)
tree9c032c7404692127d6bd4d8ae30d07b191d2d0bd /net-im
parentx11-misc/vym: Old (diff)
downloadgentoo-32f9d234b4406bf51e6faca93cc8bdea2762fb97.tar.gz
gentoo-32f9d234b4406bf51e6faca93cc8bdea2762fb97.tar.bz2
gentoo-32f9d234b4406bf51e6faca93cc8bdea2762fb97.zip
net-im/gajim: Fix QA warnings.
Replace deprecated gnome2_icon_cache_update with xdg_icon_cache_update. Avoid installing pre-gzipped man pages. Closes: https://bugs.gentoo.org/692670 Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.73, Repoman-2.3.17
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/gajim-1.1.3.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-im/gajim/gajim-1.1.3.ebuild b/net-im/gajim/gajim-1.1.3.ebuild
index 0a7ad71cae6c..54f26a180bee 100644
--- a/net-im/gajim/gajim-1.1.3.ebuild
+++ b/net-im/gajim/gajim-1.1.3.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{5,6} )
PYTHON_REQ_USE="sqlite,xml"
DISTUTILS_SINGLE_IMPL=1
-inherit gnome2-utils distutils-r1 xdg-utils
+inherit distutils-r1 xdg-utils
DESCRIPTION="Jabber client written in PyGTK"
HOMEPAGE="https://www.gajim.org/"
@@ -67,12 +67,20 @@ RDEPEND="${COMMON_DEPEND}
RESTRICT="test"
+src_install() {
+ distutils-r1_src_install
+
+ # avoid precompressed man pages
+ rm -r "${D}/usr/share/man"
+ doman data/*.1
+}
+
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}