summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorマリウス <marius@xn--gckvb8fzb.com>2022-05-01 13:52:45 -0500
committerFlorian Schmaus <flow@gentoo.org>2022-05-02 16:53:35 +0200
commit43cdbe6e3dbbb9ce84275d6326a89e81b142592f (patch)
tree56798d764c09ba7fa0930b032365831a2f0e153d /net-im
parentnet-analyzer/gvmd: bump to 21.4.5, drop 21.4.4 (diff)
downloadgentoo-43cdbe6e3dbbb9ce84275d6326a89e81b142592f.tar.gz
gentoo-43cdbe6e3dbbb9ce84275d6326a89e81b142592f.tar.bz2
gentoo-43cdbe6e3dbbb9ce84275d6326a89e81b142592f.zip
net-im/profanity: version bump to 0.12.1
Co-authored-by: Florian Schmaus <flow@gentoo.org> Signed-off-by: Marius <marius@xn--gckvb8fzb.com> Closes: https://github.com/gentoo/gentoo/pull/25279 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.12.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 10964d81786e..f343d5aa16e5 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,2 +1,3 @@
DIST profanity-0.9.5.tar.gz 830966 BLAKE2B fc1b755b1a92dbde62aacb31cb5d9190cea951e98501a5b48495dbd31266f343cf436de1fa0f69caec34324cd1f781d0bd4f5f7ebdd984324c5d1d6edb91452a SHA512 79305ee488d3a9b87bb422d6525bfaae62c4969d466b968c86941ed5bf0c0080e349758f2e1ead144693513b5d19a635372e73aa1fe9e362836b9245e1d2b898
DIST profanity-0.11.0.tar.gz 887566 BLAKE2B 373b49670d00aa741e1957a8d3ca0282f6e7215c53c6c89088268d92fa6bd8f396e6c8e69f17aeb65f9183f620376613672c7f71c879ece31b97382df5d7a781 SHA512 14164921e151a9201728afc3835e08649036702d1fcdef6e37f83de6da4b9bd9c5e9ba54db69e3a9e16fb7e360369b4e92b6b771bc5e005e343a9a526738a268
+DIST profanity-0.12.1.tar.gz 895566 BLAKE2B 8e9a0e21ad598c5fdde293e38b9b6fb363ae06f424e7fd11d12a01ec6d5ce39a83849e56e284c15a842f01d66f3a4011f9518aef3a521459f690a7d052fe591f SHA512 ca3ea92fd439336cd0bf0be42afdda464e25be85b910aef837738b8d1787ac174ac93ccee4fb2fb385228ed7be8e9bac5e96a1f89a68df162785b17d7671463f
diff --git a/net-im/profanity/profanity-0.12.1.ebuild b/net-im/profanity/profanity-0.12.1.ebuild
new file mode 100644
index 000000000000..17175e193d4e
--- /dev/null
+++ b/net-im/profanity/profanity-0.12.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://profanity-im.github.io/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify omemo otr gpg test xscreensaver"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-db/sqlite:3
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/libassuan
+ dev-libs/libgpg-error
+ >=dev-libs/libstrophe-0.11.0
+ net-misc/curl
+ sys-libs/ncurses:=[unicode(+)]
+ virtual/libcrypt:=
+ media-libs/harfbuzz:=
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ omemo? (
+ net-libs/libsignal-protocol-c
+ dev-libs/libgcrypt:=
+ )
+ otr? ( net-libs/libotr )
+ sys-libs/readline:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? ( dev-util/cmocka )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable omemo) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(with_enable xscreensaver)
+}