summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-01-27 12:04:54 +0100
committerWolfram Schlich <wschlich@gentoo.org>2016-01-27 12:04:54 +0100
commit4c5e95e68e30fca5479e4de3190fdefb0a9cc3ad (patch)
tree15320014b3e5a27f08c8dad0c1f08d8efe22f333 /net-im
parentnet-libs/loudmouth: switched back SRC_URI to github now that the release tag ... (diff)
downloadgentoo-4c5e95e68e30fca5479e4de3190fdefb0a9cc3ad.tar.gz
gentoo-4c5e95e68e30fca5479e4de3190fdefb0a9cc3ad.tar.bz2
gentoo-4c5e95e68e30fca5479e4de3190fdefb0a9cc3ad.zip
net-im/mcabber: version bump; sys-libs/ncurses dependency fix
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mcabber/Manifest1
-rw-r--r--net-im/mcabber/mcabber-1.0.1.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/net-im/mcabber/Manifest b/net-im/mcabber/Manifest
index 4de926d868b0..c94c1a9b4522 100644
--- a/net-im/mcabber/Manifest
+++ b/net-im/mcabber/Manifest
@@ -1,3 +1,4 @@
DIST mcabber-0.10.2_p20131025.tar.gz 399025 SHA256 90f4e583a7ea929abcd243dc970d64db53f1f577a4a76dc55432eaa86b5ce007 SHA512 4910acfb3d0f6341e0926bff740186d3039a47f15fd075409ecd940b6388b9bb3bf35cb88eb675e6063eaefba6f4421ca7c07e18cb307a1c7b3206c077feeeb1 WHIRLPOOL 12b9ea8d5dd2e70afeeaab18f8361bd57a5c9850bfc70e953800efe5319d632881163c48d904efc07aadb9cb1a33c09d9b034537e4fe3102793da084bd246e97
DIST mcabber-0.10.3.tar.bz2 612153 SHA256 77466138496cc26db125145cc28dc4fc0df79827143b922dfb9f02eb0dc7fa6d SHA512 3f4c83dbe99f1e1981a89d2a9cdfbaf96b265aaabe133e41d562491557e0acc2d780ae88aa3e45eca9088318ef7d7b284f1df445d2b5afb139d5a247e111bc10 WHIRLPOOL 7139d7b44837026276b269f5d911486bc898ef4c72d0cec2ada066636f284c00205b207241024d4311a82f7eb6a83590dbf402167dec4441e477f6166a7595b5
DIST mcabber-1.0.0.tar.bz2 602173 SHA256 5476bcba395e0b9527823f5a9bce725151756f685ce2dcf6fad3dbe50a157032 SHA512 bad8af15ed984ac0a568ea497464a3fa9b3ba3dea51cdd4042361be10783bba3578859ced532cd2c1cf19588fc42bdd561486b9fce6ed2da86a509e29c26c497 WHIRLPOOL f9eba52f2686f0571947e006ce825378be7f00db8192988e5a071a86160c48b113609fe4f539d61191378348333763c24e013f5bc69863f4b41a54264313e3f8
+DIST mcabber-1.0.1.tar.bz2 604661 SHA256 579a45a2bc944455012ca9b308f7f3454efabbe0c36c6723af761aa1f3092d93 SHA512 23b268fb0c4e5ce0f28333d2b35fa8b6ead819359c0e2a633158bdcb637040c23deb2ca54d7d1a98a8a8fa37323bfe078371e790b5809af76fe9b940529f728c WHIRLPOOL 9e5a2478a5bc7c8d35526bb81178842e04a5367b23cd7ec8dfa303069a6ad75ae74411977b9f354d3758c80a6ed578a4caf4c21cdb5322feece818d50e053a6b
diff --git a/net-im/mcabber/mcabber-1.0.1.ebuild b/net-im/mcabber/mcabber-1.0.1.ebuild
new file mode 100644
index 000000000000..3fc2a585428e
--- /dev/null
+++ b/net-im/mcabber/mcabber-1.0.1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic autotools-utils
+
+DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
+HOMEPAGE="http://mcabber.com/"
+#REV="a18e1b488f1c"
+#SRC_URI="http://mcabber.com/hg/index.cgi/archive/${REV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://mcabber.com/files/${P}.tar.bz2"
+
+#S=${WORKDIR}/${PN}-${REV}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="aspell crypt idn modules otr spell ssl vim-syntax"
+
+LANGS="cs de fr it nl pl ru uk"
+# localized help versions are installed only, when LINGUAS var is set
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done;
+
+RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 )
+ otr? ( >=net-libs/libotr-3.1.0 )
+ aspell? ( app-text/aspell )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ idn? ( net-dns/libidn )
+ spell? ( app-text/enchant )
+ dev-libs/glib:2
+ sys-libs/ncurses:0=
+ >=net-libs/loudmouth-1.4.3-r1[ssl?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+## autotools-utils.eclass settings
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS ChangeLog NEWS README TODO mcabberrc.example doc/README_PGP.txt )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.3-vim-ftdetect.patch"
+)
+
+pkg_setup() {
+ if use aspell && use spell; then
+ ewarn "NOTE: You have both USE flags 'aspell' and 'spell' enabled, enchant (USE flag 'spell') will be preferred."
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable crypt gpgme) \
+ $(use_enable otr) \
+ $(use_enable aspell) \
+ $(use_enable spell enchant) \
+ $(use_enable modules) \
+ $(use_with idn libidn)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # clean unneeded language documentation
+ for i in ${LANGS}; do
+ use linguas_${i} || rm -rf "${ED}"/usr/share/${PN}/help/${i}
+ done
+
+ # contrib themes
+ insinto /usr/share/${PN}/themes
+ doins "${S}"/contrib/themes/*
+
+ # contrib generic scripts
+ exeinto /usr/share/${PN}/scripts
+ doexe "${S}"/contrib/*.{pl,py}
+
+ # contrib event scripts
+ exeinto /usr/share/${PN}/scripts/events
+ doexe "${S}"/contrib/events/*
+
+ if use vim-syntax; then
+ cd contrib/vim/ || die
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins mcabber_log-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins mcabber_log-ftdetect.vim
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "MCabber requires you to create a subdirectory .mcabber in your home"
+ elog "directory and to place a configuration file there."
+ elog "An example mcabberrc was installed as part of the documentation."
+ elog "To create a new mcabberrc based on the example mcabberrc, execute the"
+ elog "following commands:"
+ elog
+ elog " mkdir -p ~/.mcabber"
+ elog " bzcat ${EROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
+ elog
+ elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
+ elog
+ elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
+ elog "manual page (section 1) for more information."
+ elog
+ elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
+ elog "See README_PGP.txt for details."
+ echo
+ einfo "Check out ${EROOT}usr/share/${PN} for contributed themes and event scripts."
+ echo
+}