summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYu Gu <guyu2876@gmail.com>2022-04-23 14:58:54 +0800
committerJoonas Niilola <juippis@gentoo.org>2022-04-23 10:32:17 +0300
commit503e89d0bc5fe1ecbf6822bd3f8a388497c5b1e4 (patch)
treed948b7dc242eb4395191c92ad50ba7e7e859e5fa /net-im
parentdev-python/doit: add 0.36.0 (diff)
downloadgentoo-503e89d0bc5fe1ecbf6822bd3f8a388497c5b1e4.tar.gz
gentoo-503e89d0bc5fe1ecbf6822bd3f8a388497c5b1e4.tar.bz2
gentoo-503e89d0bc5fe1ecbf6822bd3f8a388497c5b1e4.zip
net-im/err: revbump to 6.1.8-r1 to fix a bug
Remove unsupport argument reconnection_interval from irc backend. Signed-off-by: Yu Gu <guyu2876@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25161 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/err/err-6.1.8-r1.ebuild93
-rw-r--r--net-im/err/files/fix-irc-backend.patch18
2 files changed, 111 insertions, 0 deletions
diff --git a/net-im/err/err-6.1.8-r1.ebuild b/net-im/err/err-6.1.8-r1.ebuild
new file mode 100644
index 000000000000..11312c0984ea
--- /dev/null
+++ b/net-im/err/err-6.1.8-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_PN="errbot"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Multiprotocol chatbot designed to be easily deployable and maintainable"
+HOMEPAGE="https://errbot.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/errbotio/errbot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES="${FILESDIR}/fix-irc-backend.patch"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="irc +xmpp"
+
+DEPEND="
+ acct-group/err
+ acct-user/err"
+RDEPEND="${DEPEND}
+ dev-python/ansi[${PYTHON_USEDEP}]
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/daemonize[${PYTHON_USEDEP}]
+ dev-python/deepmerge[${PYTHON_USEDEP}]
+ dev-python/dulwich[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ irc? (
+ dev-python/irc[${PYTHON_USEDEP}]
+ )
+ xmpp? (
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/slixmpp[${PYTHON_USEDEP}]
+ )"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/pygments-markdown-lexer/d' setup.py || die
+
+ # NameError: name 'slack' is not defined
+ rm tests/backend_tests/slack_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local deselect=(
+ tests/commands_test.py::test_plugin_cycle
+ tests/commands_test.py::test_broken_plugin
+ tests/commands_test.py::test_backup
+ tests/plugin_management_test.py::test_check_dependencies_requi
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newinitd "${FILESDIR}"/errd.initd.2 errd
+ newconfd "${FILESDIR}"/errd.confd errd
+
+ dodir /etc/${PN}
+ keepdir /var/lib/${PN}
+ keepdir /var/log/${PN}
+ fowners -R err:err /var/lib/${PN}
+ fowners -R err:err /var/log/${PN}
+
+ insinto /etc/${PN}
+ newins errbot/config-template.py config.py
+}
+
+pkg_postinst() {
+ elog "For more backends (Hipchat, Slact, Telegram) support, use pip"
+}
diff --git a/net-im/err/files/fix-irc-backend.patch b/net-im/err/files/fix-irc-backend.patch
new file mode 100644
index 000000000000..0874e7352bc1
--- /dev/null
+++ b/net-im/err/files/fix-irc-backend.patch
@@ -0,0 +1,18 @@
+From 34df1dd98a7ce3a17c22081fadb427827b431d7f Mon Sep 17 00:00:00 2001
+From: Carlos <nzlosh@yahoo.com>
+Date: Fri, 22 Apr 2022 23:45:44 +0200
+Subject: [PATCH] Fixes #1566 remove unsupport argument reconnection_interval
+ from irc backend.
+
+diff --git a/errbot/backends/irc.py b/errbot/backends/irc.py
+index 95a8757d4..9f7e75b29 100644
+--- a/errbot/backends/irc.py
++++ b/errbot/backends/irc.py
+@@ -377,7 +377,6 @@ def __init__(
+ [(server, port, password)],
+ nickname,
+ username,
+- reconnection_interval=reconnect_on_disconnect,
+ )
+
+ def connect(self, *args, **kwargs) -> None: