summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-07-20 09:35:49 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-07-20 09:51:44 +0200
commit50d85d15175d868772d7823703684a8ae463af13 (patch)
tree725e86c2d618dd0f3917261f461799f0e974191f /net-im
parentdev-ruby/activesupport: avoid unneeded gems during tests (diff)
downloadgentoo-50d85d15175d868772d7823703684a8ae463af13.tar.gz
gentoo-50d85d15175d868772d7823703684a8ae463af13.tar.bz2
gentoo-50d85d15175d868772d7823703684a8ae463af13.zip
net-im/sendxmpp-amm: ensure correct scala version is used
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-1.1.1-r1.ebuild (renamed from net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild)14
1 files changed, 12 insertions, 2 deletions
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1-r1.ebuild
index faee439560d1..4f057429d997 100644
--- a/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,10 +22,20 @@ LICENSE="GPL-3+"
SLOT="0"
RDEPEND="
- dev-lang/ammonite-repl-bin
+ dev-lang/ammonite-repl-bin[scala2-13]
!net-im/sendxmpp
"
+src_prepare() {
+ default
+ # Ensure that the script is using the right Scala version.
+ sed -i '1 s;^.*$;#!/usr/bin/env amm-2.13;' sendxmpp || die
+}
+
+src_compile() {
+ :
+}
+
src_install() {
default
dobin sendxmpp