summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-02-18 23:59:24 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-02-18 23:59:40 -0800
commit5d06b7ab66d9967a13c8d1cd5278920275383150 (patch)
tree3d9ecdf175c1192d29adb9476e8cf352dce8235e /net-im
parentpackage.mask: Mask net-analyzer/zabbix for vulnerabilities (diff)
downloadgentoo-5d06b7ab66d9967a13c8d1cd5278920275383150.tar.gz
gentoo-5d06b7ab66d9967a13c8d1cd5278920275383150.tar.bz2
gentoo-5d06b7ab66d9967a13c8d1cd5278920275383150.zip
net-im/telegram-desktop: bump to 1.9.14
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild136
2 files changed, 137 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 428d96768723..55bd06169ea4 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1 +1,2 @@
DIST tdesktop-1.9.13-full.tar.gz 25324119 BLAKE2B 70029ea0dd68fd4be3ba540831111b79d223e059f70551a970847190b00f2aaebc13319236b2c681b2a55ee99408d20e6feea3fc3ab2fb9c97d4740fd4c6a644 SHA512 995face8a2ffb54f9f31aaa8d5a26421f4915e73360945553b6fa4e4b02431ca83ec1e72d6d2ce77f5b9daa39892859c88f7ea53c3ddbeec2cb37f27451878d2
+DIST tdesktop-1.9.14-full.tar.gz 25324084 BLAKE2B 45c071aa573541b6e483d2ae712b7f3b672c1294e8e7e624d9292f7176482f4d68069c35541019dc27fdb1c66134c29fb4d3667f1197e7085e4f8a80c8ca603c SHA512 56efa64048d23b280782b51319c0071c6cef833cb7e2584e52c6e45488577755beb85185ec9187029c425cc8d4c9c1887142687c744697e7731a15abe2846056
diff --git a/net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild b/net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild
new file mode 100644
index 000000000000..620b15ce23a9
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild
@@ -0,0 +1,136 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
+
+MY_P="tdesktop-${PV}-full"
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+alsa dbus libressl pulseaudio spell"
+
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ app-arch/xz-utils
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ >=dev-cpp/ms-gsl-2.1.0
+ dev-cpp/range-v3
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ dev-libs/xxhash
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtimageformats:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ media-libs/fontconfig:=
+ >=media-libs/libtgvoip-2.4.4_p20200212[alsa?,pulseaudio?]
+ media-libs/openal[alsa?,pulseaudio?]
+ media-libs/opus:=
+ media-video/ffmpeg:=[opus]
+ sys-libs/zlib[minizip]
+ virtual/libiconv
+ x11-libs/libva:=[X,drm]
+ x11-libs/libX11
+ || (
+ dev-qt/qtgui:5[jpeg,png,X(-)]
+ dev-qt/qtgui:5[jpeg,png,xcb(-)]
+ )
+ || (
+ dev-qt/qtwidgets:5[png,X(-)]
+ dev-qt/qtwidgets:5[png,xcb(-)]
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ spell? ( app-text/enchant:= )
+"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+
+BDEPEND="
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/0002-PPC-big-endian.patch"
+)
+
+src_configure() {
+ local mycxxflags=(
+ -Wno-deprecated-declarations
+ -Wno-error=deprecated-declarations
+ -Wno-switch
+ )
+
+ append-cxxflags "${mycxxflags[@]}"
+
+ # TODO: unbundle header-only libs, ofc telegram uses git versions...
+ # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
+ # EXPECTED VARIANT
+ local mycmakeargs=(
+ -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
+ -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
+ -DDESKTOP_APP_USE_PACKAGED=ON
+ -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
+ -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
+ -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
+ -DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION=ON
+ -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+ -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)"
+ -DTDESKTOP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}