summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-09 19:28:24 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-09 19:59:35 +0200
commit611d3cfba15d03bae72e648a5179169853af1eb3 (patch)
treebcac96663aa27ce2502df6500bf179e2c6b1464a /net-im
parentapp-text/zotero-bin: drop 6.0.6 (diff)
downloadgentoo-611d3cfba15d03bae72e648a5179169853af1eb3.tar.gz
gentoo-611d3cfba15d03bae72e648a5179169853af1eb3.tar.bz2
gentoo-611d3cfba15d03bae72e648a5179169853af1eb3.zip
net-im/rocketchat-desktop-bin: add 3.8.6
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 103d48ae6a27..733ab8528166 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.8.5-linux-x86_64.rpm 62651340 BLAKE2B 7ed30c6ac674cffa1a068fbe085aac6c17d4c6dc46101ae99b4a6528da4755b5f135f1673a0bedcb24430de21b2fad2530612e574eb1189ea88f5d58fd609860 SHA512 55724082b618265b831f8eed51d8c49d3d383e3e2df3dd495619fc13ee054d278a15b4ab03ab9f5c23dcf254387cde93da883210eaaa92263d5826e954092980
+DIST rocketchat-3.8.6-linux-x86_64.rpm 62305896 BLAKE2B 5dca26208bd965678e35a08a66d08b2fed368ccde2e991e19e6891ead9364693d0660ae3941cf3a15eb4fd3c6c18ed6f167dd33f0bfb1159fa39e0db7a31aa38 SHA512 0218a5cf0a897f3b0d0c80bd372e86791e47e6d60e291389b6554beb1d54e8e709eac733eb8ddf5686249521b990d6b2f6b43b8454f122aaea2ea95feb0c1565
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.6.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.6.ebuild
new file mode 100644
index 000000000000..258071fcfef4
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}-linux-x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}